Downward facing Lidar, how to disable object avoidance?

I have a downward facing Lidar, just to measure height accurately. How can I set this up without engaging the object avoidance? Can it possible? If possible Please tell me.

If you use the pixhawk-1m firmware it doesn’t include obstacle avoidance and your lidar will be useless and only measure distance. You can also disable avoidance with the avoid_enable parameter, and disable proximity sensor with I believe prx_enable? Don’t quite me on the prx_… But it begins with prx_

Hi @Rohan,

When it’s downward facing lidar we call it “surface tracking”. There’s an auxiliary switch option (“10”, “RangeFinder”) that allows it to be turned off. We don’t have a way to always have it turned off but I guess you could set the RNGFND1_ORIENT to be some useless orientation… like “0”.