Downloading problem for FW for APM 2.6

Hi, I have an older hex that has APM 2.6 I think and I am using APMPlanner2. The fw on the fc is set up as a quad and only four motors spin. I am trying to download the Hex fw and having problems. When I select the icon that is for hex (x style), in the log window I can see the download appears to happen but the when it tries to open that file it generates an error message

‘Unable to open file: C:/Users/Danny/AppData/Local/Temp/qt_temp.TW8044’

I have tried this several time, the last two letters before 8044 change each time I download but the result is the same. If I open windows explorer, I can see the file pop into that directory, I can even copy it out. As soon as I clear the error message, it gets deleted from the temp directory.

I tried to go manually to the site and download the file, I can find it but do not know how to download it or how to upload it to the flight controller manually.

Can anyone assist? I know it is probably a newb question but I am new to Arduino.

You will have better milage if you use Mission Planner.

Download the latest and just do the install.
It will work out that it is an older board and get the right FW for it.

Have you tried running APMPlanner as Admin.
Sounds like a file access problem.

Hi Mike, thank you so much for the reply. Yes, it seems like a file
access problem I agree. I have been working on this on and off and don’t
remember the exact path but seem to have only had luck with the
APMplanner2, except for this glitch.

I will try your suggestions, both and let you know how it worked out.

Thank you again.

Danny Vrekalic

I’ve moved this discussion to the mission planner discussion area. Setting the topic to “Blog” makes it appear on the first page of!

oh ok, thx, will learn, was not aware.

Danny Vrekalic

The advice worked. It did not go smoothly but I did manage to get the unit running and solve my problem with your advice. Thank you again.