Does OSDVideo work?

In looking at MPs “Testing Screen”, I click on OSDVideo. It brings up a screen that allows you to specify the flight video and the tlog, and the timing offsets between them. On the right side of the window, it says “Please make sure you have installed ffdshow and haali media splitter.” Screen shot below. I can’t find any posts in or on RCG that suggests that this capability works. Before I go installing codec and media splitter, I’d bee curious to know if this thing is in use at all. Sorry for the skepticism, but lack of posts suggests this isn’t well proven capability. I would love to find out otherwise.


it worked last time I checked

but is not a very used feature.

I will take it for a spin and let you know how it goes for me. How much configurability is there in the HUD setup? I haven’t found many ways to tune it in my ad hoc education on MP.


I installed ffdshow and haali media splitter, after having installed latest MP 1.3.38. Re-started MP, went to the test menu and the OSDVideo menu. Specified my video file and corresponding .tlog. Hit the start button. Laptop (Windows 7) grinds a bit, creates a video file of zero length with -overlay appended to input video’s filename. Creates a .txt file with the names of video file and .tlog, (attached here) but never does much beyond that, and doesn’t appear to grind CPU or IO. The MP console window spews a bunch of messages I couldn’t find in the Program Files (x86) directory. MP log file from that directory attached here. Last screen shot before I killed idle application is here.

Not sure what to try next.


osdvideo.txt (255 Bytes)
MissionPlanner.log (120.3 KB)

Hello everyone,

I was excited about trying this feature and seeing the result. However, after repeated attempts, the same error message was being generated. I am unable to infer the reason for the occurrence of the error. Could someone help me understand what is missing or requires updating.

Thanks in advance.

I’m getting the same error as Maximus91. Could you find a solution?