Servers by jDrones

Does not react to Joystick in Manual mode

Hello. I have a weird problem since a bit more than a week.
We have been using a Logitech Game pad controller to control our USV. Its a build with two motors, very similar in concept as rmackay9 built and used to show the loiter function in this little video here: https://ardupilot.org/rover/docs/loiter-mode.html
First problem I encountered (after updating to the latest MP) was that the button assignments forthe Joystick where not showing anymore (the right side of the Joystick window)… weirdly enough they were still assigned correctly.
I have now reverted back to the .68 MP version and the joystick buttons all are labeled corrected.
So here is my problem:
When I switch to Manual mode and increase throttle on my Logitech Joystick, nothing happens. There is no change in Servo output 1 or 3 (skidsteering). Also left/right does nothing. When however I switch to Loiter mode the rover reacts as usual, trying to keep the rover inside the loiter radius by engaging the motors.
I did a motor input check and the outputs are assigned correctly. I have attached the log file.

Any help with this is deeply appreciated to make it work again! (It did work before!)

@sailordude,

From the logs there’s no RC input detected.

It seems like the outputs are working ok which is why the MotorTest and Loiter mode (which takes no inputs from the pilot) are working correctly. Auto would presumably also work fine. So it’s really the inputs that need to be sorted out so the issue is probably that MP is not sending the messages or maybe something on the telemetry link has been modified?

Good morning rmackay, thank you for looking at the problem.
Does it matter in which way I’m connected to the AP? I have tried using the USB cable, over the wireless module (Pixracer has that sweet little module that sticks on it up on top) and over the SIK radios.
Also what SYSID settings should/must I have?
I have not been able to circle it in any closer unfortunately.
Also , when I initially connect MP to the AP it says mode “unknown” and there is also no Battery voltage. Once I “set” a mode in the “actions” screen the mode lights up and battery voltage is shown.
thanks, chris

Looks like I found the problem. I tried matching the SYSIDs in the parameters in the Full Parameter list and there was a error message. Went back into ConfigTuning / Planner window and saw that the GCS ID was set at 255. I reset it at 1 and… Manual mode works…
… O.k. I guess I can back and install the new versions of MP and AR!!!
Thanks for guiding me in the right direction, much appreciated.

hmm… this does not seem correct actually. Below is some advice

a) MP’s system id should be 255. This can be set from MP’s Config/tuning >> Planner screen.
b) The vehicle’s SYSID_THISMAV param should be 1. This can be set using MP’s Config/Tuning >> Full Parameter Tree (or Full Parameter List) screen
c) The vehicle’s SYSID_MYGCS param should match the GCS’s system id (ie… step a) and can be set using MP’s Config/Tuning >> Full Parameter Tree screen

O.k. will change the parameters accordingly and give it a try.

any advice on why initially it shows "Unknown"as mode in MP?

I deleted the local missionplanner folder and restartet MP. It recreated the necessary local files from scratch and now all seems fine.

1 Like

Great. I suspect the “UNKNOWN” issue was because the version of MP was old.

Servers by jDrones