do_set_servo and camera shutter activates 2 waypoints before

Pixhawk and mission planner. do_set_ servo or camera shutter activates 2 waypoints before the action? On apm 2.6 it activates after the preceding waypoint just like the wiki says. Cannot figure out why after many tests. So when I mission plan if I want the servo to activate I set it up 2 waypoints ahead of do_set_servo and it works fine? Am I missing something?

Hi Troy,

[mf]3DR Hardware Support/Pixhawk[/mf] Here is a better place to get an answer to your question.

Can you post the paramters saved from APM2.x and Pixhawk and we can compare. it does sound like WPNAV is set different between the two.

Dear billbonney, thank you for your reply. I tried to upload the parameter list but showed .param was not allowed for upload. I do not have the apm anymore to compare, bummer. I went out and tried it again and the servo realeases at 2 waypoints before do_digicam control and also do_set_servo, I tried both ways.

If I want to use do_set_servo I have to set camera shutter to rc10 and then plug servo into rc 11 (aux3) on the pixhawk, the servo will not activate if camera shutter is set to rc11 like it should be? I just found this out after much trial and error.

If I want to use do_digicam_control, I have to set camera shutter to rc11 and plug servo into rc 11 (aux3) which this seems correct and working normally.

Which WPNAV parameter should I be checking. Thank you very much for your help, I really appreciate it.

How can I get you the parameter file?


[quote=“troytt”]How can I get you the parameter file? [/quote]Add the param file to a zip file and try to post it again.

in mission planner it’s called WP Radius or in Full Parameters its called WPNAV_RADIUS

see … anning.jpg

I zipped the parameter file and it is now attached[attachment=0]Troy parameter list[/attachment]

I checked waypoint radius and it was set to about 180 cm which is around 6 ft. I have waypoint, about 600ft apart and it activates the servo just after the second preceding waypoint for example. (example mission) --Takeoff, waypoint 1, waypoint 2, waypoint 3, do_set_servo, waypoint 5, return to launch.

In this scenario the servo activates just after waypoint 2


Sounds like a defect, it should trigger after 3

Would this be a hardware or software problem?

I really would like to get this sorted out. Can anyone take my parameter list and go and fly 500 class quad with pixhawk and activate a servo.

I am with a nonprofit ITEC. ( we do missions and humanitarian work in the lower amazon and I am experimenting with delivering Malaria medicine and snake bite venom to out villages.

I am sling loading and dropping with a servo. I need to be confident its going to drop into the village.

I have attached a pic of the test rig

Has anyone had this same problem? I have tried 2 different pixhawks both so the exact same thing?

Do set servo activates 2 waypoints before?

I am having this same problem with APM 2.5.2 and AC 3.2. It’s maddening. Any solutions? I formerly made this work fine with the same flight controller and AC 3.1, but I’m not certain it’s the AC version. However nothing else is different that I’m aware of.

Be well,
Ed O’Beirne