I set up a mission with 6 way points in a rough circle and an ROI in the middle. The ROI was the second item in the list, below the first way point. I wrote it to the copter then read it back again to check it. Although the way points were correct, the ROI coordinates had been reset to zeros, so of course it had vanished from the screen. Am I doing something wrong ?

Nothing appears to be wrong from the image displayed. I guess that is the original file before sending. What about the one you get back from the copter?

Does the reloaded file list the second waypoint or only 5.

Yes, that was the the mission as sent to the copter. The mission sent back was identical except that the ROI was reset to zero latitude and longitude. I don’t know if the correct ROI is actually stored on the copter as I haven’t been able to fly due to the bad weather here.

Sorry, I failed to attach an image with that post. Here it is.

You must have flown that mission so can you upload the bin file from the copter. It will tell use what the command looked like when it executed.

Have not see this issue in Mission Planner before, what version do you have?

There is a report that ROI’s if there are more than one do some strange things like point in some random direction as it flies.


No Mike, I haven’t been able to fly this mission yet because of poor weather. I have flown similar missions but without an ROI and this will be my first attempt at that. I have only one ROI in the mission

I’m using version 1.3.16 build 1.1.5456.14788, which I downloaded from the MegaPirateNG Flash Tool onto a Crius AIO Pro.

I wonder if I have something configured which might negate the ROI. For “Yaw behaviour during mission” I have set “Face next waypoint except RTL”, but I have also tried the other options for yaw behaviour and got the same result.



First a correction. The firmware version I had downloaded from the MegaPirateNG Flash tool was 3.0.1-R4

When I changed to 3.1.5-R2 (the only other option) the ROI was not removed and all looks OK

I’ve still not flown the mission as it remains far too windy here and looks like staying that way for some time.