Do I have to enable "Throttle Failsafe"?


I bought Pixhawk Cube.

My Hexacopter’s frame is Tarot X6(900 Class) and motor is tarot 4114 and prop is dualsky 1755.

it uses 6 cell 5200mah X 2 batteries.

and I also have APM and Pixhawk.

these 3 Flight Controller has same problem with landing.

and Im now suspecting “Throttle Failsafe” option.

I always disabled this function but I found the fact that everyone enables it.

after landing motor doesn’t stop and it try to go upside down(flipping)

can it be the cause of my problem…?

I flew many multicopters already so its not problem of controlling.

Your throttle failsafe is not causing the copter to flip on landing. It has nothing to do with anything related to landing or attitude.

This is almost always caused by prop wash hitting the baro causing it to think it is still descending. If your landing is rough, that will throw off the accelerators as well, which prevents them from cross-checking the baro. I suggest you try setting GND_EFFECT_COMP to enabled (1), which is designed to help with this. But you still need to be landing slowly and smoothly to not totally confuse it.