Do_Change_Speed command causing Auto and RTL to fail

Hi Everyone

I am flying the APM 2.6 and cannot seem to use the do_change_speed command correctly. According ot the Wiki … ange-Speed the versions before 3.2 use the first column for the speed setting in m/s. When I use a do change speed command the auto mission makes a really scary erratic stop at the point that command is issued. The moment that happens the copter (Y6B) simply loiters at that location and when I engage RTL it does not respond at all. The only way to move the machine is to use loiter, alt hold or stabilize. Re-engaging auto or RTL causes machine to hold position.

I have a theory but it is likely wrong: My trying to change the speed somehow sets the speed to 0 or very close to it causing no movement using waypoint navigation like auto or RTL… The speed I tried to set was 2 m/s. I tried entering it in both blocks. Made no difference. I do not know how to analyse the log files to see what is happening. If someone can explain to me how I will post it here.

I need to be able to use that command often. Thank you in advance for any assistance!

Has anybody tried to test this?

yes, sounds like a bug in missionPlanner (gues youre using it when you say “column”)
Try “APM Planner”

I’ve encountered exactly the same issue, which I reported yesterday here.

Did you you manage to make any progress with this problem?

Hi Andrew

The problem appears to be related to Mission Planner. When I plan missions in APM Planner 2 the do_change_speed command works. So you could simply use APM Planner but I use many of the functions in Mission planner that is not yet available in APM Planner 2 so in order to still use mission planner I devised a workaround:

Use APM Planner 2 to plan your mission and enter waypoints, the do_change_speed commands etc. as you would have if you were using mission planner. Then write the flight plan to your drone, disconnect from APM Planner and reconnect with Mission Planner. Read the flight plan into Mission Planner from the drone (so you can see the flight plan) and then simply fly the mission via Mission Planner.

It is not very smooth unfortunately and apparently the new release (3.2) has that ironed out. As soon as they release a stable version I will try it.

Please save the mission from Mission planner, then read back and save from APM planner, post the missions here.

Thanks. I’ve found why this problem exists, and another (slightly quicker) temporary workaround until I upgrade to AC 3.2, explained on the other thread ( … e=activity)

If your quicker workaround is putting the speed value in the second column I am sorry to say that one does not work either. I did quite a bit of research on it a few months ago and tried various things but nothing worked. The APM planner route is the only way I could get it to work. However if you do succeed please be so kind as to let us know. Good luck!

I put the speed value in the first parameter field, where AC3.1.5 looks for it, and set the second parameter field to 0; this worked fine on a test flight.

I’m trying to upgrade to the 3.2 rc10 beta now though to take advantage of the better support for auto survey missions.

Ok great I finally got the time to test this. Andrew your suggestion works (though I could not get it to work before updating mission planner).

The latest Mission planner update seems to have solved the problem. Using the first parameter field works. The fix seems to be that all fields have been populated with a “0” by default. Do change speed command works ok.

Waypoint transitions are very rough at higher speeds. If you are planning on passing waypoints at high speeds be sure to allow plenty of altitude. When the copter reaches a waypoint at say 15 m/s and needs to turn around the whole manoeuvre is performed extremely violently (no slow down or graceful transition) and an altitude drop of several meters sometimes takes place before recovery.

I would also like to upgrade to 3.2 since the “gracefulness” have apparently been improved but I don’t know if it is safe yet… Was hoping a stable release would have been available by now. In the mean time I guess I will have to stick to 3.1. It’s not pretty but it works ok.

AC 3.2 is still in beta; but I’ve been running AC 3.2 rc_10 for ~70 flights (surveying, mostly in Auto) without encountering any significant bugs in the functionality I used.

Thank you for that info. Perhaps I should give it a try.