DJI f450 ESCs keep beeping after calibration and unable to arm

I am using DJI f450 ARF kit with included motors and ESCs, and 3DR Pixhawk MINI. The software I am using is ArduCopter 3.5-rc1 beta testing. I followed the directions here ( to calibrate the ESCs and I could spin the motors inside the calibration mode. However, when I exited the calibration and restarted the PixhawkMINI, the ESCs kept beeping. Holding the safety switch could get rid of the beeping, but then I was unable to arm the motors. What might be the problem here? Something wrong with the RC calibration?

Hi, normally you don’t need to calibrate dji esc.
If you have the safety switch you need to use it.
Otherwise it could be the radio calibration, try to look at GCS what error is shown .

RC not calibrated : the radio calibration has not been performed. RC3_MIN and RC3_MAX must have been changed from their default values (1100 and 1900) and for channels 1 to 4, the MIN must be less than 1300 and the MAX greater than 1700.

I remember some trouble with dji esc, an extrem solution could be to remove propeller, go alt_hold, put throttle to min, disable arming_check, arm , put a little throttle to see motor turning, disarm, reenable arming check. reboot. should be good!

The DJI escs have fixed end points. You’ll need to change the low throttle end point in your transmitter before redoing the RC calibration. I can’t remember off the top of my head but I believe it needs to be below 1000us pulse width in order for the ESC to arm.

Thank you, but how to change the low throttle end point of my transmitter?

Hi actually I found the way to lower the throttle point, as seen in the picture below. But seems like it does not help. The ESC still beeps like crazy, any idea?

Thank you. But I actually tried disable arming_check, even with this, I could not arm the motors. I think the ESC beeping is not a result of arm_checking, should be because of “no signal input, or throttle stick is not in the bottom position”. Anyway, I still cannot find a way to arm the motors.

You don’t mention the DJI ESC’s model, but as a rule of thumb, the DJI ESC’s have a fixed range between 1120 to 1940 (or 1140 to 1920), but the correct range is on their wiki.

Also some, of the DJI ESC models beep if there is no signal, and that is normal. You only get signal output after you press the safety switch.

So, with that ArduPilot version you can set MOT_PWM_MIN and MAX to the DJI values and calibrate your radio normally.

I am using DJI 420 lite ESC, but I could not find their fixed range, where could I find this information.

I am having the exact same results with my pixhawk mini except only 2 of the 4 motors will arm.
I am using ArduCopter 3.5-rc1 beta

When I change the ESC calibration param in mp only the 2 motors that work are recognized and can be calibrated and the other 2 do not receive the command from the FC. However, if I plug the escs into any of my other FC they all arm without any problems

If I swap around the motor outputs on the mini the other esc calibrate but the other 2 still do not.

I have noticed that once I select the frame type after a fresh firmware upload retry all 4 motors beep in sync but the moment I click on the new horizontal frame type icon the 2 working motors 1&2 stop beeping but motors 3&4 remain to beep and will not arm after recalibration. so I’m not sure if that is where the problem is??

If there are any logs I can upload or anything else I can contribute to troubleshooting the problem please let me know. I would also be willing to send any developer who can help a pixhawk mini at no expense to help solve the problem and expedite a solution!

Also, I have the same results when I try uploading PX4 via qground control with both the stable and beta versions have the same results as the ardupilot beta firmware resulting in only 2 motors spinning.

I have 3 different pixhawk minis that I ordered directly from 3dr and all 3 pixhawk minis that I ordered perform in the exact same manner which leads me to believe it is a software issue as opposed to a hardware issue.

Thank you in advance for any help that can be shared.


PixHawk mini by 3DR right ?

Similar issue with PX4 and APM ?

Have you tried to contact 3DR so that they can give some guidance? I believe that specific FC is a variant of a variant of the Real PixHawk.


Yes and yes and yes lol…unfortunately 3DR customer service is not like it once was. I am awaiting a reply.

I just wanted to share my experience in hopes that someone has already encountered a simular problem and had any additional information that could be shared.

Those “new” 3DR boards seem to be the issue. I would go for a refund and go either to a “real” PixHawk like those sold by MRobotics, a PixRacer as sold by AUAV, or a Cube 2.1 (aka PixHawk 2.1) from Proficnc, which are a known board, for a reputable vendor/manufacturer…and also all good ArduPilot partners…

Yes you are correct on all points. The full sized pixhawk is what I currently use on all our heavy inspection platforms and it has worked flawlessly. However we have just been recently requested to build a much smaller platform and the full sized pixhawk is 2 inches too big…but the mini fit the bill perfectly. I have messed with the pix falcon and the pix racer with good results but I also felt a bit committed to 3dr because of there former history and background. It’s just unfortunate that 3dr did this to themselves especially when they were a known reputable manufacture themselves…then they decided to step away from the core diy community that they fostered and created and it didn’t help with DJI putting the final nail in there coffin with the solo flop.

Regardless, it would be nice to get this cute little pixhawk up and flying like it should be able to.