Servers by jDrones

Display Parameters Bug


(Fatrybl) #1

Hello guys,
I have a trouble with mission planner displaying parameters.
I give you a link to the video with the bug.
Description : the parametrs does not change in the window with a field and blue sky :slight_smile: So if i run a SITL simulator or even real robot sometimes params in that windows change, but if i disconnect robot , and then connect again, the params stop changing. until I restart Mission Planner.
It seems to me that the window with the field and blue sky ^) updates the params only when mission planner starts. But not when the robot is disconnecte and reconnected again.
I would try to find it myself, but hope u will show me approximate project or file or any refferrence in code, where I can handle this
A link to the video https://yadi.sk/i/NFbMuciL3YXdkA


(Andras Schaffer) #2

Some clarification. User items are not updated in the HUD after a disconnect/connect. Removing items does not effect the others, adding new item makes other items updated as well.
Will look into it during the weekend.


(Fatrybl) #3

Exactly !
Thank you. I will be wainting for some news from you


(Andras Schaffer) #4

bug found, pull request created


(Andras Schaffer) #5

Michael merged it, it will be in the next beta release.


(Fatrybl) #6

Thank you very much! i also tested it. Now it works !