Display of Telemetry Measurements

APM 2.8 with firmware V3.2.1
Quad X
Mission Planner V1.3.63

I was initially trying to troubleshoot a problem with the HUD roll axis not showing level when Quad is level. This led to trying to investigate the various telemetry measurements to discover the cause of the issue. I won’t go into the details of all the research and things I tried to figure it out, but will limit the post to the Mission Planner issues.

  1. Unable to find what we call a “Measurement List” in the Aerospace Telemetry Industry jargon. It normally shows each measurement and includes a lot of technical data including where the measurement is taken in the system, the scaling, update rate, etc. There is a lot of data on the “parameters” that are stored in the flight controller, but very little on the telemetry measurements.
  2. The screen that shows selection of measurements to be graphed is not organized and the abbreviations are not very intuitive. I have seen screen shots on various forums that show a similar screen shot that has the measurements organized into logical categories. Was this a previous version or is there some method to display this selection screen in an organized/grouped fashion?
  3. This site has a post that shows some of the screens that I would think would be more useful to me, but have no idea how to display them. Any clues?
    Look at Step 75 10.5.2
    Look at Step 103 15.2
    Look at Setp 104 15.3

After a great deal of searching on the HUD display not level issue, I found many posts where others had the same problem but the only resolution offered was some kind workaround that did not explain in any detail as to how is was doing it, what other affects it might have on something else,etc. I believe the last lines of the post was one of the programmers indicating that they knew the cause of the problem and that it will be fixed in the next release. I think V3.2.1 was that version that needed to be fixed and it is the last version I can load onto my APM 2.X.
4. I am unable to load a previous firmware version with Mission Planner. I have tried various schemes I found on the net but unsuccessful. My first attempt to troubleshoot the HUD Issue was load an earlier version and see if the problem still exists. When unable to do so, it led me into the effort to try to understand and view the various nuts and bolts going on in the controller with the Accelerometer / Gyro signals as well as the processing of the raw data. Unfortunately without a measurement list, I am bogging down in this attempt.

I notice that on the Invensense MPU-6000/MPU-6050 Product Spec, it has a nice block diagram of the sensors and signal flow. Unfortunately, I have been unable to find a flow diagram for the APM that shows the signal processing of the hardware/software after it leaves the MPU sensor. It would be a great tool for us to self-diagnose issues we find. If it exists, I would appreciate a link to find it.

Thanks in advance for any assistance.

ArduPilot evolved a lot since that version you are using, and the complexity increased quite a bit, considering the amount of available features.

First that board is not supported for some years, and those ArduPilot versions aren’t also maintained, so I would suggest upgrading to a more recent version.

Some reading of the wiki might give you an idea of the organisation of the code.

ps: a good option is to use the controller on that article if you’re willing to use a Linux based system with RT extensions.

Thanks, but I am aware of all you mentioned. There are many reasons I chose the APM controller including the fact it is around a long time, and should be stable in its software. I am not fond of being on the BLEEDING EDGE of technology, especially when a proven configuration has a proven track record. I have been burned too many times trying to use the latest and greatest product/software only to find myself stopped in my tracks when something does not work and there is no option other than to wait for a solution to be developed. When it matters, such as a customer project these kind of delays are unacceptable.

Also,into the equation/analysis is the fact that this product worked fine and met the needs of the users without all the bells and whistles of a later generation. Furthermore, the info/data I am looking for also would apply to analyzing the current software versions in Arducopter. As I understand it, the reason for the APM no longer being supported is because the new code with additional features would not fit in the memory of the APM board, not that the board did not do its job well with the existing software/firmware.

I do not expect the developers to go backwards to cure problems in the APM, they are busy with the new generation firmware. All I am asking for is the tech data which I am convinced has to be out there somewhere so that I can fix the code myself.,

Thanks for the response.


please refer to this

this is the current documentation for what is transported over the air. i say current because this documentation targets mavlink 2.0, not mavlink 0.9 or 1, which is what an APM would be using.

Thank you very much Michael for the response. This is exactly the type of data I am looking for. I havn’t yet been able to figure out how to print it, but this will be a great help.

The next step will be to find out where the measurements are being generated in the Arducopter firmware code so that I can understand the details of each measurement. It’s obvious some of them are raw sensor data and some are derived from calculations. I am sure that a flow chart or something like it must exist but have yet to find it.

First flight today was not too bad. No airborne related crashes but could not get the Autotune function to work yet the telemetry confirms the mode switches are set up correctly. The quad just stayed in Stabilize mode and ignored the Autotune function. Will have to figure that one out.

Second attempt resulted in drone flipping over on takeoff. Discovered a broken prop so stopped for the day to recharge bat and change prop. Notice later that I now have a 5 deg nose down when the quad is level. Have no idea how I ended up with this when it flew fine in stabilize mode and the Autotrim function worked fine, Performed an ACCEL calibration at home and it reset the pitch to level. Tapping on the controller with a screwdriver did not reveal any instability with the sensor or calibration.

If you have any more tips on docs to the nitty gritty of the code, please pass it on.


There is no Auto-Tune for quads on APM boards.

That’s interesting! I watched this video https://www.youtube.com/watch?v=5pqdAOCkz00 and it shows Auto-Trim and Auto Tune for APM (7/8) " APM 2.5/2.6/3.1 - Autotrim and Autotune"

Am I missing something?

BTW, when investigating at home after the flight I found a couple issues.

  1. I had mistakenly assigned the Flight Mode switches to Auto mode rather then Auto Tune. Will give it another try next flight. Me bad!
  2. I prematurely deleted the Flash Log Files when I was trying to download them in MP. All the dates were 1969 so thought they did not recorded from todays flight. There are a lot of posts on this topic and the best I can figure out is that the APM has no real time clock and the MP is supposed to convert the time to local time based upon the GPS time which is embedded in the Flash File. Apparently MP is not doing that and I don’t know why. None of the posts indicated that this problem has been fixed. Anyone know how to fix the time of day on the flash log files that are displayed in the download flash files screen?


I would recommend you to have a look at the documentation.

Although there was an option of AutoTune for the APM, the results were subpar, and only on a recent refactoring these became useful. So I would not recommend using but it is your choice.