Display of SERVO function in "Full Parameter List"

In the source code of ArduPlane 4.0.5, SRV_Channel.h,
The last part of Aux_servo_function_t is written as follows.

k_scripting16 = 109,
k_LED_neopixel1 = 120,
k_LED_neopixel2 = 121,
k_LED_neopixel3 = 122,
k_LED_neopixel4 = 123,

However, by connecting to Mission Planner,
The servo function in “Full Parameter List” is

109: Script 16 124: RateRoll 125: RatePitch 126: RateThrust 127: RateYaw

They don’t match.

I re-install Mission Planner, but it was the same.

I wonder why?
Is there a workaround?


recent parameter-relevant additions will usually be added to MP’s param metadata with the subsequent MP update per default. MP alternatively allows to manually align fw / MP parameters:

this will likely put the neopixels into your full param list:

cheers, basti

Hi, basti-san,

Thank you.

And, I woud like to ask you again.

I use Mission Planner 1.3.70,
but I never see the “setup / Advanced” menu.

Do you use beta version?
Or, is rhere any switch to display " Advanced " menu?

Thank you.

Update to Latest beta from the Help screen.

I’ll try it.

I tried to use “Paran gen” ofBeta MissionPlanner.
Mission Planner accessed to arduplane site and rewrite the “ParameterMetaData.xml”, “fwversions.xml”
and “tfr.xml”.

I checked servo funciton at “Servo output”.
It was updated.

I want to customize “Servo output” list as “SRV_Channel.h” which I changed.
Should I edit “ParameterMetaData.xml” myself?


if the code is being submitted to master, it will add it automatically. if it is a local mod, you need to edit the xml to show your option

Hi, Michael-san,

Thank you.
I’ll try to edit the file for my local version.