Servers by jDrones

Disarming Plane with Controller

Hi.
I tried to disarm the plane using my rc controller but it is not working.
I set arming rudder settings as 2 (arm and disarm the plane using rudder input).
It is OK when i give zero throttle and full right rudder and the plane will be armed.
But when i either do zero throttle and full left rudder or zero throttle and full right rudder the plane does not disarm.
I read about there is no disarm with rc controller feature in APM:Plane.
Is this true?
If it is true, why?
Also if it is true, can i set an rc input channel of apm as controlling arm/disarm status of the plane?
Thanks for answers.
Regards.

i have a same problem with you, in my case only when a GPS get LOCK then we can DISARM, never had a problem with a pixhawk

so yeah please try get a gps lock and then you will able to disarm

Hello.
The documentation says about disarm:
"The flight controller needs to make sure that you are not actually flying."
Try: Check the STAT log parameters and check flight status at the time you tried to disarm.
If Flying / isFlyProb = 1 your sensors have errors.

Hi. I’m having the same issue as well. I tried @Demerval’s suggestion but no luck. Has anyone had any luck on this?

I switched to pixhawk and never seen this issue.
Please use currently supported hardware.

Servers by jDrones