Disabling arming check not working

I am trying to use 3.3.1 rather than modified 3.1.5 and I face several problems. Here my point is that arming-check parameter set to 0 does not disable ekf gps filter.
I could move outiside my office to run tests, but please… why cannot arm the copter when security check are disabled? Should I also disable EKF?

Do not misunderstand me, APM is very nice and I use it as a professionnal but pushing new release with not updated wiki or parameters that are not documented is at least disturbing. Overall this is great job, but please do your possible to keep users confident with firmware as much as possible.

I have no problems with arming check. I clear all problems that call the errors instead of turning off the checks. The developers are professionals and are very helpful. Please don’t discredit the wiki.learn how to set up your multicopter correctly. Have fun! :smiling_imp:

There is inherently a steep learning curve.If you cannot take the time to understand how to correctly set up your multicopter,Then I would suggest you buy a ready to fly multi. Good Luck.

1 Like

Sorry for the rude message. My problem was that GeoFence was on and so arming was not possible.
I do agree that clearing errors is what have to be done for normal use. However when developping new setups and running tests not “in real flight conditions”, disabling security check is sometimes relevant. Let’s says that I compile some stuff inside the user code and need to make some tests with copter armed in my office (no props of course)…

I just made the test again:
APM 3.1.5, ARMING_CHECK=0: I can arm copter without GPS lock.
APM 3.3.1, ARMING_CHECK=0: I cannot arm copter without good GPS fix.
I found that Geofence need to be disabled on 3.3.1 to arm the copter.

Is that something done in purpose? I would except that ARMING_CHECK would override all other securities.

Don’t misunderstand me, I do not blame developpers and try to contribute. I also compile my firmware with some usercode running to specific purpose so I have some ideas about how things work.

If people want to remove this topic, please do. Maybe it would be better to post in the developper area.

Don’t misunderstand what I mean, I also compile custom firwmare versions, and therefore I sometimes need to check copter behaviour in my office, without good gps fix, or with missing compass, and of course no props and no will to make a “real flight”.

My point is that from 3.2.x version to 3.3, ARMING_CHECK behaviour was changed and do not override all other checks.
I just made this test, with bad GPS fix because I am in a building:

APM 3.2.1: ARMING_CHECK=0: I can arm, whatever GeoFence/flight modes are.
APM 3.3.3: ARMING_CHECK=0: I can only arm if I disable GeoFence, even with PosHold mode.

If I have a 3D fix but bad EKF Pos, it will trigger the message GPS HORIZ ERROR. Some people experienced this also:

I do not discredit wiki, but this may not be up to date: copter.ardupilot.com/wiki/prearm_safety_check/

Maybe we can remove this topic and continue in the github issue requests if you prefer.

So I think this issue has been discussed elsewhere and the action is to improve the arming error message. We don’t want people taking off in a mode requiring GPS without a working GPS. We also don’t want people thinking their fence is working when it’s not… and because the fence requires GPS we need the GPS to work if fence is enabled.