Disabled Pre-Arm Checks, but still cannot arm because of No 3D Fix

Is there a way to be able to arm when the GPS is not used? I want to demonstrate Mission Planner and ArduCopter indoors where I will not get a GPS fix. I want to ARM and DISARM so folks can see the states on the HUD.

However, I cannot ARM because it complains of having no 3D fix - even though I configured MP/AC to disable the pre-arm checks.

Please advise. Thanks,


What flight mode are you trying to arm in?

If it is an auto mode then that would explain the message.

Have you tried Stabilise?

Do you have a fence active?

Attempting to arm in stabilize mode, but do have the fence active. Thanks,


fence needs gps right. so the solution was to disable the fence right ?

Try disabling the GPS too, rather than just disabling that part of the arming check. That way in the case of an RTL or some other failsafe, it won’t try to use it. Regarding the fence, you do need to disable the fence if you will not have GPS. It wont’ let you arm if the fence is enabled and GPS is unavailable.


I disabled the fence, and am now able to arm without having a 3D fix. I did not disable the gyro, just the fence.

Thanks all,


1 Like