Servers by jDrones

Disable EKF on gps coordinates

(Evan Blough) #1

Hello,
I am working on a research project for precise autonomous navigation. Our rover is setup on a Pixhawk 2.4.8 that runs Ardurover 3.4.2. The rover is supposed to take photos in a soybean field. We are running into an issue with our autonomous navigation. We need the vehicle to move with precision of a few centimeters, so we have attached an Emlid RTK GPS module to the pixhawk. The Emlid works fine, but we are having an issue with the EKF. I believe the auto mode in Ardupilot uses global position int to navigate instead of the raw gps data from the emlid. It uses the raw gps data to calculate the global position int, so is there anyway to disable the filter to not change the gps coordinates from the RTK ? The RTK position is already very precise and we don’t move at speeds where the accelerometer readings are necessary. The only things we should be using to navigate are the compass sensor and the RTK gps. The rover moves in mostly straight lines and does two 90 degree pivot turns at the end of the fields.
Here are the parameters currently set on the pixhawk. If you have any recommendations about parameters we could tune or modifications to ardurover, Please let met know.
SmallRobotAugust7.param (12.8 KB)