Difficult to tune throttle in a 1 / 5 Kraton 8S RC CAR ¿way too powerful or just bad tuning?

Hello all,
I am having a hard time trying to tune the throttle response in this car, it is a Kraton 8S in 1/5 Scale, the main problem is that the vehicule seems to have too much power and I am not able to tune it. Any help will be appreciated.
First, I am using 6S batteries instead of 8S, so this should help.
I firstly programmed the ESC (Toro TS150 , 150A, for 3S-6S) to the lowest powerfull configuration: the “punch rate” is at “very weak” (lowest setting) .
then I tried it in manual mode and it seems too responsive, but I don’t what else to “lower”.
Then I tried to tune it in acro and auto modes, which is the intended way of operation for the rover.

With the default parameteres for the throttle tuning, the car stutters A LOT. I don’t know if that is the correct word, it started to move very briskily, then stopped, then move again…
Looking at the PIDdesired and PIDachieved in Mission Planner as suggested in the documentation, I think that the gain was way too high. So I put lower and lower values until I reached the minimum value of ATC_SPEED_P = 0.01 . Even at the lowest value, the rover do the stutter when accelerating, so I lowered ATC_ACCEL_MAX to 0.8 and now, at least, when the rover starts to move, does not stutter too much.
BUT, even with this configuration (lowest P, low I, low ACCEL_MAX), I have still too much overshoot in the PIDs, like in this screenshot:

The overshoot is very clear for increasing and decreasing speed. And PIDachieved never approach PIDdesired, so I added some I (ATC_SPEED_I=0.05), but, still, the overshoot is too much and getting the desired speed takes several seconds.
I don’t what else I can do. I have lowered the parameter MAX_THROTTLE from 80% to 30% so the full range of the motor power is not used, but the rover still is achieving more than 5m/s and behaviour is more or less the same.
I am sure there should be an easy fix to this problem but I can find it. Is there any other parameter I can lower to get a smoother result?
Any help will be much appreciated!
Best regards and thankyou in advance,

telemetry logs: Sign in to your account

dataflash logs: Sign in to your account

Hi @Adolfo_Cobo,

I think the core problem is the CRUISE_SPEED and CRUISE_THROTTLE parameter values.

  • CRUISE_SPEED = 2.936

I’m sure you followed the instructions on the wiki but I suspect that when the aux switch was moved to capture the values the vehicle hadn’t reached its top speed.

In any case, the current value means the vehicle will drive at 2.9m/s at 30% throttle but I suspect it travels much faster at 29% throttle. From a peek at the logs we can see at 24% throttle it reaches about 5.4m/s and it might have gone even faster given more time. So I think it might be best to set CRUISE_SPEED to more like 7 (m/s) or maybe even higher.

One method that might work is to set the ATC_SPEED_P, I and D to zero while you’re trying to get CRUISE_SPEED right. Maybe use the real-time display of the PID’s desired and actual (see wiki here). Then once you’ve got the CRUISE_SPEED value close (e.g. the vehicle travels at roughly the right speed) try increasing ATC_SPEED_P and I to help improve accuracy and get rid of the oscillations.

1 Like

I didn 't suspect of CRUISE_SPEED as I followed the procedure and the values seemed reasonable to me. I’ll try your suggestions once it stops rainning :roll_eyes:
Thanks again for your helpful response!

I changed CRUISE_SPEED to 7 m/s (CRUISE_THROTTLE=29) and everything works fine now! @rmackay9 you were right as usual. Now with ATC_SPEED_P = 0.15 I get a very good value for PIDachieved.

Looking at the logs, I guess that speed for trhottle=30% is more like 5m/s, but I don’t want to change it further, good enough as it is.

1 Like