Diatone Mamba H743 V2 with MK4 firmware

Question - has anyone loaded the MambaH743v4 on the V2 board? All the resources appear the same but the V2 has wifi.

Want to get Ardu on this FC and did a quick check before buying but missed that small detail - and cant find the V4 board anywhere.

Thanks

Yes all good. v4 actually means “Mark IV”. The hwdef has been updated for the v2 variant

Thank you kind sir. Was curious as the picture shows the older board as well…

I am flying a build with the v2 right now

Andy,

Im having a HELL of a time - getting message that barometer cant be initialized, disconnects when I try to calibrate the accel, and no response from the radio. Been using Matek boards with no issues, but this one has me stumped. Any words of wisdom?

Thanks

The baro is a power issue - these boards really require battery power if you have anything at all connected. The bare board is just about ok, but with a GPS connected - forget it.

I’m assuming you are loading 4.4.4 which has support for this board.

Yes sir, 4.4.4 Ill power the board with battery then plug in after to see if that helps. With batt in Still not seeing the crsf on serial 1 (UART1) which has me scratching my head.

And just like that I figured it out. I need to power the board with battery before connecting to ARDU and then all is well with the system. This is going to be painful to program and not overheat the vtx and chew up batteries…last build with this board for me.

guys, I have a problem with the gyroscope, it doesn’t work. I downloaded inav and everything is fine, but when working on ardupilot it gives an error of poor gyroscope health and on telemetry the horizon is in a fixed position. And this happens every other time, sometimes it starts up well and everything works, but the next time it’s buggy. What to do ?
Mamba mk4 v2 h743_2022b dual icm-42688-p

I have two of these with no issues at all. One thing you could try is reducing the clock rates in hwdef, e.g. change:

SPIDEV icm42688  SPI1 DEVID1 MPU6000_CS   MODE3   2*MHZ  16*MHZ
SPIDEV icm42688_2 SPI4 DEVID4 MPU6000_2_CS MODE3  2*MHZ  16*MHZ

to

SPIDEV icm42688  SPI1 DEVID1 MPU6000_CS   MODE3   1*MHZ  8*MHZ
SPIDEV icm42688_2 SPI4 DEVID4 MPU6000_2_CS MODE3  1*MHZ  8*MHZ

Hello Today I tried to flash ArduCopter V4.6.0-dev and so far everything is working well. I will test further. Thank you very much for the recommendation!
by the way there is no mpu6000.
can you explain the difference between these firmwares? before that it was 4.5 stab

4.5 stab should work. Older revs of the board had mpu6000, the firmware copes with both types

In general, I decided to flash it again to the stable version via mp and everything worked, but the settings were lost. The main thing is that it worked!