Destroyed 2 3Drobotics Pixhawk / APM Planner 2 waypoints?

Could someone please explain the difference between Mission Planner and APM Planner 2(Mac)? We have been trying to build a functional quad to carry a sensor array we’ve developed using a Pixhawk, 3dr GPS/Compass etc… We’ve now gone through 2 kits. Both completely destroyed.

The 2nd unit we built was working quite well in every flight mode as we tuned and worked our way through. As soon as we switched in to Auto mode this afternoon, it shot off at full throttle (which with this setup is significant) until ultimately hitting the ground at somewhere around 60-70mph. Needless to say it was a total loss.

I should note that we are quite aware that it’s in all likelihood “user error” but there were simply too many instances with APM Planner 2 where we experienced “unexpected” behavior having not made a single change.

Which platform is more stable?

Is there a single location where one can find an APM Planner 2(Mac) detailed guide other than this one: All we’ve been able to find are guides for Mission Planner which at first seem quite similar but once you get in to more complex issues, do not apply.

For instance a common question … there are more than a few settings in the config area’s which were set to “disabled” by default and they appeared to be somewhat important. Does every new setup need total calibration of all of these parameters or just the ones mentioned in the “Mission Planner” setup guide? Are we simply not doing enough?

For the sake of the question let’s say I was a film maker wanting to carry a $30k RED Epic (example). If you were advising someone building a brand new multi from the ground up and using APM Planner 2 to carry extremely valuable payloads, where would you send them for instruction or advice or any help in trying to decide if we should be looking at a different platform?

APM Planner 2.0 is the newer kid on the block, though it was based on another program called QGroundControl. The idea being a cross platform version of Mission Planner.

Some option on the autpilot are disabled by default, as they need to be setup correctly before they work as expected, i.e. throttle failsafe

For us to help determine what is not working out for you it would be great if you can post the dataflash logs from the flights. You can copy these off the SD card in binary form, or download them in text form using terminal.

If you can also post the APM Planner 2.0 logs we can also determine issues from that. See your home directory under apmlanner2 for some files named log.txt log.txt.1 etc…

If you saved your mission files that will also help

Sorry to here about your crashes, but we can help try and find the reason for them.

Also a picture of your setup is also helpful (pre crash if you took some)


I did read your answer in a different post where someone had mentioned not being able to “launch” or lift off from the software itself . You explained that while in the “flight plan” tab the features in the “unmanned systems” widget would not launch the unit and considered removing that temporarily. So I attempted several other areas, mostly the “Actions” tab in the Info view. None of which worked. Kept getting "Unsupported command: 22 or 252. A few different codes deepening on what we tried.

I finally decided to add the “Auto” mode to a switch on the TX, load the waypoints, start the flight in Alt_Hold and then manually switch to Auto. That was the last flight.

Here is a link to the entire contents of the APM folder after downloading the 2 files from the flights today. They are obviously the last 2 BIN files. The other BIN files were simply not cleared before today’s test. I can send the entire contents straight from the onboard sd if you prefer:

There were only 2 flights today. One in Alt_hold, and the next started in Alt_Hold and was switched to Auto after a few seconds. They are time stamped with today’s date (the last 2 bin flies).

The quad setup is as follows:

3DR Pixhawk
3DR uBlox GPS with Compass Kit
3DR Radio Set
Spektrum DX7s w/satellite on the quad
T-Motor - MT4006
T-Motor S25A 600Hz ESC’s - SimonK
Carbon Fiber 10x4.5 props
DJI 450 frame
Battery 4C - 2700mah - 25C

Here’s a screen grab just after the crash and the quad just after build. Well after I walked a while to retrieve the remnants. The MAV 001 widget was flashing red at the time:

Not sure if this makes a difference with regards to the data but it was very windy.

Honestly the team was very impressed with the performance in other modes (Alt_Hold for instance). And like I said I’m sure this is “user error”. Just wondering if building one from scratch like this might be “out of reach” for our skill-sets. We really only need the basic waypoint autonomous abilities. Hopefully we can figure this out.

Thank you.