Degrading GPS Signal/Integrity

I’ve been struggling with this for 5 days now. Basically, no matter what GPS I use, I can never get a good enough fix to use any kind of auto mode. Sometimes I can never get a fix, sometimes When I plug in, It’s perfect and then one minute later its a mile off and eventually just loses all sats. Sometimes it seems to be better the higher I go and sometimes that does nothing.

That was the summary, here comes the whole thing…

The gps I’m using is a bn-880. Found here: https://www.amazon.com/gp/product/B078Y6323W/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1
I’ve used this for a project in the past with great results. I have it on a mast, although it helped nothing. As for picking up any satellites, it seems to be pretty random. Maybe altitude helps? But when it get s a fix it goes all over the place, like hundreds of feet. Always moving. Then eventually it will lose the fix and it won’t come back. I’ve tried using tinfoil to increase the size of the ground plane, it seemed to get a fix faster but it didn’t do anything for the accuracy. I have plugged in my other bn-880 that I know works and had the same issues.

Recently I hooked up a micro m8n GPS. Found here: https://www.racedayquads.com/collections/gps-units-modules/products/micro-ublox-m8n-gps-glonass
It worked fine on the same drone when it was running inav. Lo and behold it jumped all over the place. But it always has a fix so I just disabled the bn-880 and am now using just the compass.

I’ve tried allot more but most of it seems to be irrelevant. I can’t really explain, but I have a hunch it’s ardupilot related, not interference or anything like that. But I could be wrong.

Just to get it out of the way, yes, I am using the right voltage and have tx/rx the right way.

Thanks in advance for any hints!

Hi what other equipment do you have, I had similar issue together with raspberry pi and a camera. They needed shielding to get good result from the GPS. I think I read that 1.3GHz radio also might interfere.

The bn-880 is not a good GPS. I gave up on it. Other GPS’s are fine in the same vehicles the bn-880 wouldn’t work.

Just as a datapoint I recently switched from a shielded board camera to a runcam split and my Matek micro GPS (over the camera) went from 9 sats to 21. So do be careful with your VTX equipment…

1 Like

So I just put both the micro m8n and the bn-880 on taller masts and now both always have a fix. However, the location always jumps all over the place. Even when both have more than 6 sats. Bn-880 always about 8 and micro m8n about 11. I’ve tried disabling each one at a time as well as blended and use best modes. But I still get the jumping issue.

What is interesting is that when I reboot just the fc, (kakute F7 aio) via ctrl f and “reboot Pixhawk,” when it comes back the location is pretty accurate. Less than about 4 ft. Then, after 10 seconds ish… it gets progressively worse.

I thought this might be because of interference from the telemetry radio reconnecting so I tried over usb and unplugged the radio. Same problem.

The bn-880 is not a good GPS. I gave up on it. Other GPS’s are fine in the same vehicles the bn-880 wouldn’t work.

I agree it’s not great but it has worked well for me in the past and regardless it shouldn’t be a mile off when pretty well isolated on a tall mast.

I’m going to put put inav on it and see what happens.

Let us know your results.
Lot of poor GPS quality posts in the forums lately, but I really don’t see how it could be firmware related.

Personally, with no changes to my copters, I have been getting zero or maybe 4 satellites for the past week, or a little over a week, when I usually get 10-15. It happens sometimes… Not sure why. Either the military messing w/ the GPS system, or something local to my area causes interference at times.

Well… I was about to do a backup from mission planner before flashing inav. I realized that the quad icon was pretty stable and accurate. This was inside, while it was raining!

Eventually I found that when I disconnect from usb and connect via the telemetry radio, it gets worse and I eventually lose all sats. I checked this over and over and eventually unplugged the telemetry radio and BOTH the micro M8N and bn-880 had a perfect fix. Again… inside and raining!

Now keeping in mind that I tried this exact thing outside on a clear day with the same hardware (minus the M8N) I’m a little skeptical. I’m going to wait for tomorrow just for a sanity check.

But assuming I somehow missed a PERFECT fix, what do I do? I can turn down the output power but I doubt that will be enough. I have one other telemetry radio to try to test if the interference is due to a faulty radio. But I’ve only ever used that radio on my autonomous lawn mower project where there was 5 feet of separation between the GPS and any other electronics.

What type of telemetry are you using? The traditional 915mhz SiK radios?

What type of telemetry are you using? The traditional 915mhz SiK radios?

Yep. Right here: https://www.amazon.com/dp/B085NXH3N4/ref=cm_sw_r_cp_api_i_5YllFbV40CBK2

It’s very possible it’s just a bad unit. Although it does feel like a higher quality than the only other sik radio I’ve used before. (Which is probably a little on the sketchy side to be using on a lawn mower)

Those should work. Try the other radio. And otherwise, try shielding the radio circuitry w/ some copper foil tape. It helps with camera interference.

But also test again on another day. I’ve also had clear days outside w/ poor signal, and a storm the next day and I get 15 satellites inside my basement.

@InitialFPV The GPS receivers that you mentioned in the first post are both cheap Chinese crap. No surprise that they get interference from telemetry radio or your PC via USB.
A good GPS uses genuine Ublox module, usually (but not necessary) have LNA and filters between the antenna and the GPS receiver. The bad news is that they cost around 50-60 bucks.
For 15 usd you got what you paid for.

@Eosbandi The $15 one is just a tiny GPS designed to just give a home arrow and maybe GPS rescue on a 5” racing quad. Doesn’t even have a compass. I threw it on there just for a sanity check while trying to figure this out. I’m just using what I have on hand for this project.

Ok just tested again. Outside and relatively clear. It’s definitely the telemetry causing the problem. Same thing happened, unplug, works, plug, kind of works, and if I use it, its 200 ft off. How I missed that before I have no idea.

So I put some tin foil on the radio, it gets better, but EKF still doesn’t clear. I find that if I lower the tx power to 5, it sometimes clears without tin foil. Its 500mw so I guess that would be 125?

I put the other radio on and its pretty good.(no tin foil)

It’s very possible the output power is just too high but it came from amazon so I’m going to return it and use the other radio in the meantime.

Anyone have a suggestion for a new Telemetry radio. Not paying more than $40.

so, gps is usually affected greatly by the other noise you get from other components. worst offenders are runcam devices. but, anything can be the reason.

use shielded cables to the gps unit only, make sure all is grounded and use a grounded backplate under the gps puck. it is usually a good test to try initially your gps unit with a flight controller alone - you can feed it from the 4.5v FC produces - plug it directly, get it outside and memorize how fast and how many sats it gets during its initial bootup. very first boot-up will take time, but, it is still helpful to memorize how quick and how fast it goes. a m8n unit with no interference should catch 4-5 sats failrly quick, then wait and go to 8-15 sats and remain there.

it your built model powers up and all you get from the gps is 6-7 sats and the ground speed param keep jumping non stop - it means you have interference coming from either power feed - use filters, or into the signal cables. then you can either wrap cables with copper foil, or, find a proper shielded cable with 5 signal wires in it and use it.

for telemetry - if you do not need it for longer than a 100m or so - use an esp8266 chip, it will bring wifi connection directly to your laptop. there a different varieties of those chips with different power output and antennas. simplest/smallest ones work for 30m or so.

if you need a smallest gps - i used this one a lot, and it is reliable enough.
https://www.amazon.com/gp/product/B07GS56Z73

Don’t buy any telemetry radio that claims 500mw. As a experienced heli pilot once posted on here the only way those noise producers would work is if you towed them behind the craft on a long cable. I think Andras @Eosbandi would recall that dialog :slight_smile:

Perhaps the Holybro branded units (100mw) would be OK.

I was able to get amazon to replace it with this: https://www.amazon.com/dp/B01DHV4DVA/ref=cm_sw_r_cp_api_i_euRmFb7EVBHQ0

I don’t need perfection, just functionality.