Defect in Loiter mode

Hello everyone, this is my drone, I’ve been working on it for about 3 months, it’s a dron that can carry 7kg as payload and I don’t know how to improve its behavior, I see it slow and unresponsive, I tested the default parameters and almost crashed, my drone is a quadcopter with engines T-engine U10 II 100kv with supports of 30’ and esc calls, I tried autotune medium mode without payload, this improved, but I still feel that at any moment this can fall in loiter mode, If I put it in altitude mode or position hold works perefect but if I put it in loiter mode it gets worse, I checked the vibrations and FFT but it looks good
I don’t think the blame is on PID, because as I told you in others modes its behavior it’s Good,if anyone can help me,I’d give them the thanks , I put the log in the next link(this log is only with 5kg as payload)

Most probably your MOT_THST_EXPO and MOT_MIN values are not correct for your propulsion system, and that causes instabilities.

Does that mean 30" props and what about the ESC’s?

Tuning is terrible and your Notch Filter configuration is doing nothing. 2 FFT notches configured with no reference. Churning loop time is all.
You don’t want to use an Auto Tune Aggression of .05. Set it back to default but in any case no lower than .075.
You do not want to run an Auto Mission with this poor level of tuning. Go back to basics, set these back to default (they are too low):
Then configure One (1) notch filter properly. I would suggest using throttle based not FFT (disable that). And then run Auto Tune.

yes it can be , those values I put them to test and error, I don´t have a laboratory bench to know the curve of these motors, that would recommend me ?

I´m sorry thee traslator, yes I’m using 30" props and esc flame from Tmotor
Ok I’m going to put default values in ATC_ANG_PIT_P, ATC_ANG_RLL_P, and set the notch filter based in throttle, with cut-off frequency at 87 Hz and 40 Hz bandwidth
thanks for your time
I’ll tell you how I do

30inch props will have a frequency around 30Hz
Use throttle-based harmonic notch filtering.

Hello everyone, I followed your recommendations, I set the filter based on the accelerator at 40hz, and I set the default PIDs, It flew relatively well, it was slow when braking but in general the behavior was better, then I continued with the autotune at 0.75 and everything got worse, I almost crashed the drone, I leave you the log (2023-04-25 12-28-28)
Given that the behavior of the drone was deteriorated, I set the by default parameters, but its performance was no longer the same that I got at the beginning of the day, so I tried to do manual tune by myself but it was still very bad, I attach the final log (2023-04-25 13-16-56) .
I look fordward to have any advise from you, thank you very much