Dataflash fails

The logging feature in APM 2.5 (AC 3.1) is not working for me anymore. Most of the time, when I connect to terminal, I see “3Erasing logs” message:

After clicking “Log Download” button:

Some crazy log numbers. There should be one log only (one arming - one flight performed).

If I click “Download all logs” the process hangs with the grey message “Createfile”:

If I choose to download only one log, it starts to download and hangs shortly after:

Only read to 2338, that’s it.

Trying to dump through CLI:

No luck here either.

Sometimes it connects with message “3No dataflash inserted”:

And after reconnect it sees the dataflash again.

Even if I disable logs, it still starts with “Erasing logs”:

Also, if you noticed, my log disappeared after I tried to download it through CLI.

  1. I checked the regulator via outer pins on I2C like in Randy’s video - it’s exactly 3.3V
  2. Erased or cleared logs (in CLI and via “Clear logs” button), disabled-enabled different types of logs and all of them at once too.
  3. Erased EEPROM on the board, did reset and reboot.
  4. Reflashed firmware and did full recalibration of everything.
  5. Reinstalled MP (my version is 1.2.92)
  6. Tried different computer with different OS and MP version. It let me download a log from second attempt but the file was corrupted - it was only a piece of log and column names looked like korean hieroglyphs.

I gave up at this point. The copter was tuned up and flying great, I had no hardware changes preceding the failure, never had any crashes or hard landings. I was just flying it for the last few days and was sometimes downloading logs to analyze performance and vibrations.

I wonder if the board can be further safely used or I should dump it in the garbage (it’s past 3dr 90 days warranty). Any insight on this problem would be greatly appreciated.

I guess this thread is quite old but it’s got to be some kind of hardware issue with the dataflash chip. You could set the LOG_BITMASK to zero to disable logging and it’ll probably be ok if the hardware problem is just with the dataflash chip itself (as long as it’s not just a symptom of a more general hardware failure).

Sorry I can’t be of more help.

Just replaced the board to be safe, thx.