D_shot Brushless motors, not spinning when armed

I’ve attached my params for this current build.

This is my first Ardurover project, and second Pixhawk project (always used Betaflight/ Inav)

Likely I’m just missing something basic since I’m new to this system.

I have my hardware all hooked up, steering servos configured, tuned, and tested. I have followed the tutorials for setting up D_shot (running D_Shot300 to avoid slow refresh/noise issues I keep reading about) and when I click to test motors, I get the musical tone, and nothing. Bump up the throttle on the controller, nothing.

I’m using a T_Motor 55A BL_Heli32 4in1 ESC, driving 4 independent 6010 130KV brushless motors on 2S.

All motors are set to the same channel, motor 1 via the Params, and to run D_Shot300, all pins have been switched from PWM out to the AUX 1-4 pins, which through params were set up to run D_Shot.

I keep trying to come at this from different angles, and am about to watch a youtube video to learn how to do pass-through so I can get into BL_Heli32 configurator and set/ verify the settings on the 4in1.

Plan is to set the ESC to run in “3D” mode, which will put the midpoint throttle at zero, and essentially allow me to pull off forwards and reverse.

I’m using HereLink for control, which is somewhat helpful for the settings I am able to adjust via the controller.

Any suggestions would be appreciated. I know this is achievable, I just need to get these motors moving so I can move on to figuring out gimbal control.


15Sep19 params.param (13.5 KB)

Will those ESC’s even run on 2S or is that a typo?


I’m going to dig through ESC’s and look for something that runs 2S, if not, run 3S, and regulate the voltage for the steering servos

Thanks for pointing out the obvious thing I overlooked.

Alright, swapped power system to run on 4S, motor test (Yes they work) and configured ESC for 3D, braked mode, etc through Betaflight FC.

Configured all settings in Mission Planner, and found this! or did not find… where’s SERVO_BLH_AUTO?

without this option, I dont think I can fully enable the motors.

I can run motor tests for 1-4 with those commands, which I have, and I get beeps, but I dont think its enabling the motors, because Ardurover doesnt have this function included in the FW build?

If its not included in the FW for Ardurover, is there a way for me to compile a FW where I essentially copy and paste that relevant data from the Copter data?

Sounds like a nightmare, but as easy as it would be to run this off a dragonlink receiver and run analog video, I am really trying to incorporate this Herelink control system for all the cool functions ardurover can offer…


Current Params:17Sep19Params rover.param (13.5 KB)

You don’t need the AUTO parameter. Just the set the mask channels. Looks like it should work as iyu have configured it on chan 9-12

Ya, strange that I’m getting the motor beeps, and no response from the motors in Dshot. I switched back to the PWM pins on the board, and am running everything on PWM, works fine, settings carried over from when I connected a Betaflight FC to configure my 4in1 ESC. Braking works, forward and reverse. Brushless motors are cool. Silent and these 6010’s have decent torque.

Next step is to attempt and reconfigure the motors to a “Wye” configuration to increase torque and decrease RPM’s

Thanks for the help.

It just might be an issue that hasn’t been fixed yet. It’s one of the few things still on the issues list.