Custom Speech Callouts?

Anyone know how I could create custom callouts of specific parameters at a configurable interval? I see the default few options in Config / Planner section. I like my current settings of callouts uponflight modes, waypoints, etc… I’m pleased with all of that.

But… I want Mission Planner to call out Airspeed at a very frequent rate when a channel is set from my transmitter (I will figure out how to make the selection on the channel). The thing I could use your help with is how do I tell Mission Planner “In addition to the settings in the image below, I also want to configure you to call out parameter ABC (ex: asp) at an interval of X seconds (ex: 2s).”

I can’t find that anywhere. I could do this very easily using OpenTX via Logical Switches, but I’m unable to find how to make this custom configuration in Mission Planner.

Really appreciate the brainstorm.

If this is impossible In mission planner… think there’s a way to pipe it over to some other application that can call out a specific parameter at a requested rate?

You could try to alter the 30s callouts. It won’t be triggered by a switch like you’re looking for but it might be a start.

I’m not sure what you’re asking for is possible, but you might want to look into playing with the scripting.

You might want to try to ask the same question in the Mission Planner area here. (I can move this post if you want). Maybe some of the others who don’t looking to Arduplane might have an idea.

Oh, I thought I was in the right place! Sorry, newb. Yes if you think there’s a better place to move this, please help.

I was growing worried about that. Honestly I’m a little blown away I can’t just have the speech engine callout any parameter I wish. Figured it would be as open as OpenTX where I could just tell it to play a value when a logic switch or global variable was triggered. Have done this for years with OpenTX. "Please just say this value: "

I’m sad that I’m over here thinking about replacing my receiver just to add a smartport so that I can get MavLink parameters into OpenTX simply so I can have my Taranis process numerical parameter values that my MissionPlanner GCS already has… grr.

And I realize many are thinking “why do you want that?”, but I promise our engineering R&D use-case necessitates this.

MP is very powerful. You can do a lot of things. Doesn’t mean it’ll be easy or straight forward.

I think the 30s callouts might be the easiest, but like I said, I’ve never played with it. But I can see some valuable use cases for it and for what you’re doing.

If you’re using OpenTX, you may also look at Yaapu telemetry (if you haven’t already).

check out “warning manager” you can add custom alerts. its in the advanced menu.

Holy cow that’s it!!! Thank you just what I was looking for perfect!

But… I worry I found a bug. When I change the interval it saves correctly and I can close out of the “warning manager”. But… the next time I open it the interval will ALWAYS reset back to the default of 10.

I tested it and when I set it to “2” and saved the callout happened every 2 seconds. But the next time I opened “warning manager” not only did the “interval” change from 2 to 10… I also then only heard my callout reduced to once ever 10 seconds.

Should I report such a finding somewhere to help the community?

Thanks!

Actually… it’s not just the interval that gets reset anytime one opens “warning manager” popup window… it’s all settings. Even your custom message you saved the previous time you were in “warning manager” will get wiped and replaced with "WARNING: {field} is {value} the next time you open the “warning manager” window.

Any idea how to adjust the # of decimal places of {value} through this “message” area of the “warning manager”? Ex: {value} for airspeed called out… but only to the nearest whole number.

I use Warning Manager to let me know if my GPS is not in the RTK Fixed status. I have not had any trouble with it resetting back to a default:

I have not tried a different interval, however.

1 Like

can you give an example of what your setting? just so i can check it out

Interesting. I see your interval and your message are the default. I wonder what happens to you if you try to change those, close out Warning Manager, and then reopen it. Do they get set back to default interval and message?

Those are the only two items in the warning manager that appear to reset for me anytime I reopen Warning Manager.

Using the version of Mission Planner below:
image

Sure, @Michael_Osborne !

I first open Warning Manager and set up airspeed less than 22. The “message” and “interval” columns are the default as shown below.

Next, I change my message and repeat interval to something custom, as shown below.

I click “save” and close Warning Manager. I hear the callouts behaving with the new custom message and interval.

Next I open Warning Manager and see the defaults restored as shown below. The second I open Warning Manager, the audio callouts start sounding like the defaults again. Behaves as if opening Warning Manager is resetting the Message and Interval contents.

yes there is a bug. it is saved correctly, but when reloaded defaults are loaded. so i need to fix.

hmm. I guess I didn’t know that gpsstatus was the default. Lucky me. I assumed I had set it to that way back when I started using the feature.

new beta version in 10 mins

2 Likes

Hey, now… that’s service!

You’re the man! Thanks!

Is there an easy way in the “message” field to specify number of decimal points? So that speech isn’t calling out hundredths of a speed. :slight_smile:

Hey @Michael_Oborne I think something is up with that beta release you did for this issue.

I tested my basic warning that calls out “Airspeed is {value}” and tried interval of 3. It did it every 3 seconds a couple of times… but then it started only doing it once every 10 seconds. So I got out my stopwatch and sure enough… every 10 seconds exactly.

Next I changed the interval around to various numbers, saving each time, then set it back to 3. And this time it was every 12 seconds exactly. I let it play for a few minutes and randomly later… it started saying a couple every 3 seconds, but then would go right back to every 12 seconds.

So basically… I don’t think that anyone can use the “interval” setting because based upon my testing of it… it might work… but it probably won’t give you the requested interval.

I can try to make a video of the failure if that helps you. Let me know if this description makes sense. Don’t know if this is a clock or race-condition… but something is very odd about the interval.