Custom DTM follow terrain flights

Hey,

I’m trying hard lately to make a follow terrain flights based on custom DTM maps that I made.

I created DTM maps in Pix4D and exported it to Mission Planner thru global mapper in a 32-bit float resolution.

I succeed to see that the mission planner is using my DTM map - in the height information in the flight plan window, I see geotiff heights.

But in the bottom line, when I tried to fly based on these maps, the drone isn’t following the terrain height successfully.

I tried a lot of things:
tried to change the terrain_spacing parameter from 100 to 1. (when the parameter was under 30, the SD cannot load the data and got lots of error messages (bad logging, no IO threat…)
tried to clean the pixhawk’s SD and write mission with only DTM on the mission planner folder, with DTM and SRTM and with DTM and only general SRTM files.

Nothing made it works.

I’ll be really glad if someone has an idea that can help me or see something that I missed.

Thanks,
Guy

More information is required

what firmware
what version
what MP version
etc

Pixhawk 2 firmware 3.5.5
Mission planner firmware 1.3.62.1
I’m pretty sure that the version is the one from the Microsoft store.
The map accuracy is very precise, up to 1 meter error.

Is there more information that I can give you?

I thought it related to terrain spacing parameter, do you know to tell me exactly what does it mean?
Cause I couldn’t really understand it from the ardupilot web.

Meeting the same problem …
High precision DEM, Issues with changing the Terrain Spacing parameter under 30.
When flying with terrain spacing=30 the drone is not following precisely the DEM, there is between 3 to 4.5 meters diversity between the drones height to the DEM when going over the logs.

Any help ?

Have you solved your problem of precision DEM tracking? If yes, how ?

there was a bug found in the AP_Terrain library recently. that might have been the cause of this.
Mission planner supports any terrain spacing, however autopilot might need testing.

the latest release of plane fix’s this

This is a first post/question … so it may not be quite targeted properly

We are looking for advice on how to upload a high resolution LiDAR derived DTM into Mission Planner such that we can to fly a gamma sensor under an Acecore NOA. Its small study area ~10 hectares

We’ve not had much luck finding a pathway / user notes on to do this.

Were are assuming a wgs84 geotiff (geographical decimal degrees) …

Any advice, or links to howto would be greatly appreciated

Cheers

Guy

  1. Open MP
  2. press control-f
  3. click the DEM button (centre right column)
  4. click open DEM Dir
  5. place your wgs84, egm96 geotiff in the folder that just opened
  6. restart MP to be sure,
  7. verify on the flight planner screen, the location and alt in the top right should show Geotiff, and also it should now show in the steps 1-3 above

the reason for egm96 is because 99% of users use a ublox module, that defaults to egm96 as the default geoid, so to make all things equal, this needs to match

let me know how you go.