CurrTot is reported too high in Pixhawk log (Mission Planner)

Hello :slight_smile:
using 9000mAh LiPo I suddenly realize that the ampere consumption is reported way too high.
The Lipo is 6S with a 9000mAh capacity. The flight time is about 17 minutes. I have to recharge nearly 7400mAh to full charge the Lipo again. But in Mission Planner the " CurrTot" value is close to 15000mAh when I look into the log file. So MP is reporting two times the real amps consumption.
My other hexacopter reported correct values.
So I guess there is a switch or a divider in Mission Planner to get the real value?
(The power module is calibrated with MP)
Any hints or proceedure how I can fix this?
I hope it is not an update issue from ArduCopter v.3.5 … :disappointed:
Thank you!

Never mind.Wait for a dev to commen.But I have seen advice to flash to latest MP beta release.

Update to the latest version of Mission Planner and this problem is rectified.

1 Like

Ok, thanks :slight_smile: I’ll wait for some hints to solve this.

@ Matt: thank you for reading my question.

so I upgraded Mission Planner and also the Hexacopter firmware from v.3.3.3 to v.3.5
The strange issue persists. I still find the double mAh usage per flight.

The Lipo is 9000mAh, 6S from Tattuu

This is from my flight yesterday after upgrading everything :scream:

What more can I try or correct?

There is a voltage divider.Amperes per volt on the power module screen.Sounds like you need to halve your value.

1 Like

Thanks, that solved the inaccurate used current display.
The video for the volt and amp calibration enlighted me for the fine tuning.
Solved! :smiley: