Servers by jDrones

CubePurple - Hangs 'Checking for Param MAVFTP'

I think this may be a continuation to the issues others have experienced with Mission Planner and MAVFTP in other vehicle types when MP hangs on the ‘Checking for Param MAVFTP’ dialog.

What is most interesting is that it has happened all of a sudden. We have been working with these Cube Purple in Rover platforms (several) the past few weeks with not much issue. On Friday, they all just decided to quit working with several different MP installations.

Tried QGC, no better.
Tried performing the CTRL-F ‘driver clean’ and re-install. No joy.
Tried decreasing baud rates 115200 -> 57600, nope
Tried hitting ‘Cancel’ at the dialog, nope

Everything we try results in MP crash. Any ideas?

MP version 1.3.74
ArduRover 4.0.0

No one has seen this?

Dealing with this problem currently - I just went back to firmware version AR 3.5.1 and the autopilot loaded params just fine. I updated 3.5.1 to 4.0 but had no success…

It would be interesting to know if you temporarily set LOG_BACKEND_TYPE to zero rebooted and then tried connecting to see if Mavftp will complete. No matter what happens set this back to what it was, just an experiment.

I changed the LOG_BACKEND_TYPE to 0 and got past the MAVFTP finally. I put the param back to 1 (as it was before) and it worked for a few iterations. I tried on another laptop just to see if the results were the same but it got stuck loading the MAVFTP again. The only way it works is keeping the LOG_BACKEND_TYPE at 0, not sure what this param does exactly…

This enables flight logs. This was an experiment. Page down to the bottom of this link for info. But frankly I’m not sure why it helps with the Cube Purple, it’s supposed to have 2Mb flash.

https://ardupilot.org/copter/docs/common-limited-firmware.html#common-limited-firmware

Servers by jDrones