Servers by jDrones

Cube Orange Parameter Resets

Twice now, when I have rebooted my Cube Orange it as lost all loaded parameters and went back to the default settings (as far as I can tell, all of the default settings).

The Cube Orange is new out of the box. It was flashed correctly. I then used a Cube Black parameter file and copied over the settings that I needed (not a full copy over, not a copy and paste kind of thing).

During diagnosing this problem I did short the power between the servo power connector that was only attached to the carrier board of the Cube Orange, I don’t know much about reverse/over voltage protection on the the Cube Orange but could that have damaged the autopilot or carrier board portions somehow?

Could there be a parameter setting or perhaps a conflict of settings that could be causing this?

This is the parameter file that worked in my cube black configuration and was used to populate most of the cube orange parameters:

Nimbuss 1800 VTOL Params v2.2.param (21.3 KB)

Have you updated the bootloader?

https://ardupilot.org/copter/docs/common-bootloader-update.html#updating-the-bootloader

There is a known param reset issue with the older boot loader.

Are you using the latest stable FW version? It has some fixes for this issue.

I have not updated the bootloader specifically, but the FW version I flashed was ArduPlane 4.0.6, I’ll look into the bootloader flashing.

Ok, here is what is displayed on my Messages tab:

10/12/2020 11:56:42 AM : RCOut: PWM:1-12
10/12/2020 11:56:42 AM : CubeOrange 003D002E 3239510D 38363839
10/12/2020 11:56:42 AM : ChibiOS: d4fce84e
10/12/2020 11:56:42 AM : ArduPlane V4.0.6 (036ad450)

Should I use Zadig to update the bootloader even though 4.0.6 should fix the problem? When I flashed 4.0.6 I do not recall seeing the additional update the bootloader button that is pushed in the video at the bottom.

I’ve got no problem doing this (seems easy enough) I just don’t like dick’n around with hardware that is this deep.

No need for Zadig, just press the button on MP.

Ok, all done. I’ll report back if this does NOT fix the issue. Thanks guys!

How do i know if the bootloader actually updated (besides not having a param reset happen).

AFAIK there is not a difference in the mavlink response message for a successful bootloader flash and an unsuccessful bootloader flash. I added a Lua script to play a short set of tones a short while after boot. That lets me know that the SCR_ENABLE parameter is still 1 and not the default 0. It’s a terrible work around. I’ve been kicking around the idea of adding a feature to compare the current parameter set to one that is stored on the SD card and send a “Parameters Confirmed” status message.

I ask because I can still get the “update bootloader” button which makes me think it needs an update…

Chad, just been through the same thing. Updating the boot loader by clicking the button seemed to make no difference to my params randomly resetting

Servers by jDrones