Cube Orange Not Connecting to Mission Planner

I’ve been at it for few hours now and I’m unable to connect my orange cube to Mission Planner.

From this site ArduPilot firmware : /Tools/MissionPlanner
I downloaded latest mission planner and driver file. Both files ending in .msi.and installed them. When I go to device manager, my com port reads “ProfiCNC CUBE - New Driver Required (COM17)”. It’s weird that it can sense the cube but a driver is still missing and I can’t figure out which driver I need.

If I open up Mission Planner, I’ll select Com17 115200 baud rate and click Connect. After 30 seconds, I get the message “No Heartbeat Packets Received”

When I click Details, I get the following message
Please check the following

  1. You have firmware installed (How can I do this without connecting to the Missoin Planner, maybe that’s the main issue)
    2 You have the correct serial port connected (which I do)
  2. PX4 - You have the microsd card installed. This isn’t PX4, but orange cube and yes 16GB card is installed
  3. Try a different USB port (I’ve tried all 3)

So can you please tell me which driver I’m missing or how do I install firmware without using mission planner?

Thank you for your help

You should only need the “MissionPlanner-1.3.77.msi” file as it will get the drivers during the installation. Perhaps you overwrote good files with bad files.

1 Like

I was able to install the firmware under Set up - Install Firmware Legacy. If I go to Set up - install firmware, I get the error that USB is not conn

Is there any reason why I’m unable to install from the “Install Firmware”?

@dkemxr

Try updating Mission Planner to latest beta from the button at the bottom of the help screen.

I recently went through this with a cube orange on a laptop that had recently been issued to me (read: didn’t have all my usual software on it). While I had the latest beta of MP I ended up having to install QGC to get all the drivers I needed. Once I did that I was able to install the latest firmware with MP.

We have a similar issue, Somehow shocking how nasty it is to get the cube orange connected to mission planner. You would hope it to be plug and play! Here is our issue:

We have windows 10 pro. We finally removed our mission planner and installed the latest Stable mission planner, Run it as admin, then opened Contr+ F screen to Clean Drivers

Downloaded driver.msi files as prescribed

Then reboot Mission Planner, connected the Cube orange and found this:

Com4 ProfiCNC CUBE – New c, in the box of port options, but not the necessary one for the cube orange…

In device management same issue under port:

ProfiCNC CUBE - New driver required (COM4)

We followed instructions on this page and yet do not succeed…