Servers by jDrones

Cube newbie trouble


(Johan Pettersson) #1

I have built a X-UAV Talon with a Pixhawk 2.1 and a HERE2 GPS. It is not fully setup yet but everything is connected (airspeed sensor, LIDAR TF02, ESC, Servos) and my receiver is bined with my transmitter. It is power by Airbot.

When I am powering the cube, the LED´s on the GPS is lit for a second (arm button is not) but then everything turns black. Cube gets a red light on its base but It also turns black after maybe three seconds. GPS does not get any satelite lock at all and mission planner gives me the message “No GPS”. ARM button never lights up. I get the melody from the Pixhawk and I can connect to mission planner with a USB-cable. Pixhawk is powered from 4S LiPo.

I read all tutorials I can find here and I am lost. I read about problems with bad IOC on Cube boards but my frst question would be; Have I missed something or is there a trouble with my Cube?


(Mike Boland) #2

Have you checked the voltage coming from the battery sensor?
Should be around the 5.3v, but have had the odd faulty one.
When you power from the USB only what lights up?
Have you tried removing all the lidar, servos,esc’s?
Whenever you have issues like this just focus first on getting the Cube only working before plugging stuff into it.


(Johan Pettersson) #3

I did measure input voltage at the plug for the Cube and my multimeter showed me a steady 5.3 volt. I have everything connected at the moment but I will try to disconect everything.
I tried to load a older firmware and i get the pixhawk tune but a two tone at the end? Same thing with newest firmware. It’s flashing red att the base when i reboot. Gps is flashing red one time with the side leds and then turns black.


(Johan Pettersson) #4

Three questions:

  • Should the base of the cube be red or green after a succesfull firmware installation?
    My one is red.

  • When are the HERE2 GPS antenna side LED´s illuminated?
    My ones are all black - no illumination during configuration.

  • When is the ARM switch LED lit on the HERE2 GPS?
    My one is never illuminated and Cube does not react when i press this one down.


(Shawn) #5

Have you unplugged all external devices and just powered the cube from USB only?
If that doesnt work you may need to try and reload firmware or talk to your supplier.


(Johan Pettersson) #6

Thank you for your reply.

So here´s what I did:

I disconnected everything and connected the power brick in from HEX and put a new firmware. Then I started my Cube up again and now the GPS is working. I then started to connect all again and It appears to be a problem with my I2C (airspeed sensor) connection. When I connect this the GPS goes dark.


(Johan Pettersson) #7

Update:

New firmware loaded and I2C cable is replaced. GPS and armswitch is now working! Seems like the bad I2C cable locked everything up.

Here is also another problem I encountered:

I installed a TF02 lidar in Serial port4 in accordance with the wiki here but it did not work.
I found out after a lot of troubleshooting that the TF02 uses to much power for the Serial port4 and the only way is to feed the lidar with a separate 5v supply with a common ground from Serial port4.

I hope this helps anyone with connection problem.

Thank you for your help so far.


(Pablo Neme) #8

Hola posiblemente tengas cambiado los cables del sensor de velocidad tendrias que googlear pinout y buscar bien la coneccion para mi es eso.
Saludos