Servers by jDrones

cube 12S settup voltage not working

Hello,

I am currently building a drone on a 12s setup.
But i have issues with the voltage reading on the cube so i can set functions like rtl on low battery and so on.
I am on the 4.0.1 rc2 firmware and use a mauch power bec.

Does anyone have the same problem or have a fix to make it work?

kind regards

Can you elaborate on this a bit more? What issues are you experiencing? If you’re just unsure how to configure the applicable parameters to get the right readings, this is detailed in the wiki page for the Mauch power monitors: https://ardupilot.org/copter/docs/common-mauch-power-modules.html

Yes ive tried different settings and multiple mauch bec but they all dont work

When i use the bec that comes with the pixhawk it works (on 6s the bec doesn’t support 12s) but when i plug in the mauch bec it doesn’t read the voltage correctly.

For example when i set the voltage on the pixhawk to 50 volts and plug in a 6s 24 volts it still reads 50 volts so the value doesn’t change

I’m not sure what you mean by “set the voltage on the pixhawk to 50 volts”. That’s not something you would do and there is nowhere in the parameters to do that so I’m not sure what you mean by that. The wiki shows which numbers to enter in the parameters, which requires referencing the data sheet sent with the Mach that tells you the voltage divider and a/v values.

The parameters for low/critical voltage failsafes (wiki docs) are never going to work properly if you do not configure the power monitor parameters first.

hello

when i installed the mauch bec i needed to calibrate it on the pixhawk.
so i measured the battery voltage on the lipo for example 50 volts.
that number i put in by the red Arrow you can see on the picture bellow.

this is how i normally install my battery monitor and with the yellow bec provided with the pixhawk this normaly works but i am using a mauch bec for 12s because the yellow bec doesnt suport 12s.

i ve also tried the instal it using the voltage devider value provided with the mauchh bec but it also doesnt work it displays for example 0,56 volts instead of the correct amount

The instructions in the Wiki do not include manually entering 50 volts into that field. That isn’t what that is for. Please try following the instructions in the wiki page I linked to for properly configuring your power monitor.

Servers by jDrones