CUAV X7 safety LED not working on copter 4.1

Hi randy,
I think i found a problem with copter 4.1, the safety led not flashing on CUAV x7 and It’s only on X7, I flashed 4.0.7 It’s working, and also I tried 4.1 on CUAV v5 It’s working too.

1 Like


Great, thanks for this. I’ve added it to our “requires investigation” list for 4.1 so it won’t be forgotten.

Copter-4.1.0-beta2 will be released late tomorrow so after that you might want to re-test to see if it’s been resolved but I don’t have any reason to think it will be.

In any case, thanks for the report, I suspect we can get this fixed up.

@XinChengGe where is the safety led you’re referring to? Is this on the GPS? If so, which GPS and how is it connected? (CAN?)

@tridge It’s not on the UANCAN, It’s direct connect the FC, but It’s no longer a problem now, I tried beta3 this morning and It’s working now, but I have another issue about IMU heat, Sometimes I check the press_temp on the MP, sometimes the temperature is very very high, like 75 degrees, and I have a X7 pro connected over a hour, the ‘cube’ part is very very hot, the MP keeps showing Initialising Ardupilot’, I think it must damage some sensors lead to initialise failed. I am not sure if it’s a software issue or not. I haven’t found a pattern to repeat the issue, but I’ll keep trying.


I tried to reproduce by uploading beta3 to my CUAVx7 but it seems to be working OK for me. The board is not rebooting and the IMU temperature seems to be staying around 45 deg (which is what the BRD_IMU_TEMPTARG is set to) and the “press_temp” is down around 45deg.


This doesn’t mean that we don’t have a software problem of course but simply I’m unable to reproduce it. Do you have any ideas about what may be special about your setup? Can you provide an onboard?

Thank you so much for the investigate. unfortunately, I don’t have any log since I’m not arm the vehicle, also It’s happened on the beta1 not beat3, sorry about the wrong info, and I can’t reproduce it either, then I take a look about the IMU heat code, although I’m not good at it, but there is software temperature limitation, and one thing I noticed is, the FC won’t boot via USB, only can boot on the external power supply, I guess there must have some hardware issues.


No troubles. So the issue with the FC not booting via USB is probably because the PC can’t provide as much power as the FC requires. It may be because the PC’s USB is too weak (another PC may work) or it could be that there are extra peripherals attached to the autopilot that consume too much power (high powered transmitter perhaps like an RFD900?).

Logs will be created even when disarmed if LOG_DISARMED = 1.

Txs again for the reports.

No problem, Randy.
you are right about the USB power, but nothing attached on the autopilot, and I’ve got a new autopilot with the beta1 installed, It’s boot normally, so I’ll try to find the hardware problem, since I’m kind of Electronic Engineer.
one more problem about IMU heat, which sensor used to messure the temperature in the IMU heat system?

1 Like


Great, thanks for the extra information. I guess the new autopilot is also a CUAV X7?

Re the IMU heater, it uses the heat reported by the IMU itself. So this temperature can be seen in the logs either in the IMU message (see the “T” field) or in the “HEAT” message. I see now that in my copy-paste above the message fields being graphed did not appear so here it is again.

Thanks!! The new autopilot is X7 pro and the old one too.

1 Like