Cuav V5+, firmware error,second compass not found

Hello, everyone,
the following firmware problem has occurred.
I have a Cuav v5+ with Neo V2
Ardupilot V4.0.4-RC2.
But the following problem has also occurred with earlier versions:
After installing the firmware with MP there was only one compass and not 2 compasses as before.
When connecting the V5+ to QG, the error message was the same as with the stored photo.
The problem also exists with a brand new Cuav V5+.
When trying to read in an older parameter file, error messages appeared as shown on the stored photos.
The binary file is also in the cloud.

Can anyone help me solve this problem?


here is the parameter file.
07072020nach Flug crash.param (18.6 KB)

One compass is not detected. Can you check if i2c lines (SDA1 and SCL1)on the GPS plug are really plugged, one line could be off.

Capture d’écran 2020-07-08 à 16.57.51

Then reboot your V5+, connect with Mission Planner and go to the Compass calibration screen:

Capture d’écran 2020-07-08 à 16.54.18

and see if one compass is still missing (Offset line will be red)

Check also HW ID page:

and Compass configuration parameters:

Do the same test without plugging the GPS. If you still have one compass missing, it is the one from GPS card (external compass), maybe due to prior crash.

If both compass are missing, it could be a defect with CUAV v5+ cube compass.

I checked the plugs and couldn’t find anything wrong.
It would also be unusual for two identical systems.
I have a V5+ that is 2 months old and a V5+ that is 10 days old. Both have the same problem.
I have carried out the tests.
Only a compass is available.
It does not matter if the GPS is plugged in or not.
It can also not be because of the crash because the new system has the same problem.
So it is a hardware problem?

My CUAV V5+ is set with arducopter 4.0.3 (latest stable). You could try it and confirm if it is hardware problem.


I was able to isolate the problem.
I got a system up and running on the table.
Both compasses were present.
Then I ran the setup step by step and checked that both compasses were still there after each step.
After calibrating the Esc’s the 2 compasses were no longer present.
There must be a software problem here afterwards.

It’s all completely illogical.
I tried to get the flightcontroller running with the same procedure as before. without NEo V2
-force bootloader
-firmware plane

  • force bootloader
    -firmware copter 4.0.3
    And then this display appeared under compass.
    The flight controller should not have known that there was a second compass.