Servers by jDrones

CUAV Pixhack v3 - Temperature Dependancy of IMU0 Gyro

(Harald Schmid) #1

Hello

I have 7 CUAV Pixhack v3, but with one I had an interesting finding yesterday.
Everytime I fly this drone I have a big stability problem with the first flight. The drone is drifting or even speeding up in pitch direction when using Alt Hold mode and Stabilize mode , but only at the first flight. After landing the gyro of IMU0 has an offset of 40-70 in y direction. With the following flights after power up calibration no issue anymore.
Yesterday I identified that this is a temperature effect. With the first flight the IMU is cold. With power on calibration it is set to zero. During flight the temperature of the FC increases as well as the offset of IMU0 gyro Y and the instability increases as well. The gyros of the other 2 IMUs are fine.
I attach a picture where you can see the temperature depandancy.
Any idea how to solve that beside switching of IMU0.

BR
Harald

(Harald Schmid) #2

Update on that issue:

First I have to say thank you to CUAV for the excellent support. Although I did not buy the Pixhack v3 in their shop but at a dealer, they immediately contacted me to solve the problem. I was in contact with Lindy via WhatsApp and answers came immediately all the time. Congratulations for that great customer relationship.
They asked me to open the Pixhack and send photos. There was an idea about a faulty IMU. Finally I swapped the IMU with the one of another Pixhack v3 and the problem moved with the IMU to the second Pixhack.
With the IMU of the second Pixhack on the 1st Pixhack the problem dissapeared. So it is obvious that there is something wrong with the IMU of the 1st Pixhack.
I asked them now whether they can send me a replacement IMU.

Harald

1 Like
(Luís Vale Gonçalves) #3

Hi @Harald

Moved this to the CUAV area.