Cruise mode - not tracking straight

I have made some changes to the throw of each servo, so I first did a short autotune (only a minute or two, autotune had been run extensively in the past). I then tried CRUISE mode, and found the plane wandered to the right quite a lot. How can that happen? I thought CRUISE mode flew the plane straight regardless of wind, trim, etc, whenever the sticks are centred.

there was some wind, but not enough to do this, I think.

2021-03-03 15-13-03.tlog (436.4 KB)

Make sure the plane’s calibrations are correct. Accelerometers and Level. In the log it looks like every time you neutralize your roll input the FC is demanding 7.5 degrees and not level. I noticed it both in FBWA and Cruise.

That’s really helpful, thank you @Allister. I did calibrate accelerometer recently, but not level. I will do so and try again. Thanks!

@Allister, I checked the level calibration today and found it was way off, as you described. Thank you!

1 Like

I did calibrated level and did a full gyro calibration, then did a couple of flights yesterday. I think I had exactly the same problem - the plane wandered heavily to the right. very heavily. I tried it in FBWA and Cruise.

I don’t understand how a flyable plane can do this in cruise mode. I thought Cruise mode creates a waypoint 1km in front of itself and navigates to it, so even if my plane has a bent wing or something, it’ll find a way to get there.

I can make circles clockwise or counterclockwise, so the plane is capable of banking both ways. it just does so WAY better to the right than to the left.

is this mechanical or software?

thanks in advance.

Here’s an idea:

Edit: The roll value is still 7 degrees when everything is neutral. Same as before. The roll tuning looks good, just not neutralized.

Edit again: The RC1 Trim is 1400. But your radio is inputing 1500 when there’s (I’m assuming) no input. Try RC1_TRIM = 1500.

I’m coming back to this thread to update it and say that I found the problem - I was using a prop that rotated the wrong way. Plane is a pusher and should have been using a pusher prop, but the kit came with a tractor prop. After changing props, this problem disappeared.

Thanks for the help everyone. cheers!