Crossfire telemetry and RC setup, is it working the real world?

Hey :slightly_frowning_face:

I am working right now on a mapping quad, that i want to equip with crossfire and use that as mavlink/telemetry to connect my GS to.

Setup:

  • pixracer
  • crossfire nano
  • Tango 2 , laptop with mission planner via WIFI
  • Arducopter 4.1
  • crsf 4.11

|UART1 |/dev/ttyS0 |WiFi (ESP8266)||—|—|—|
|USART2 |/dev/ttyS1 |TELEM1 (flow control)| → this should be the right one?
|USART3 |/dev/ttyS2 |TELEM2 (flow control)|

Transmitter Settings:

  • CROSSFIRE OP Mode: normal
  • WiFi: active
    Receiver settings:
  • CROSSFIRE RF Profile: dynamic
  • Telemetry: active

RC by MAVLink
hear horrible things like lags and so on, maybe stick with SBUS as its proven?

cant get it to work, is there anything i missed ?
Thank you!

@andyp1per

Connect ch1/ch2 to the UART. Do not use RCIN. You don’t need to connect ch3/ch4. Make sure ch1/ch2 are setup for CRSF in AgentX

1 Like

will try ASAP! good to know that crsf connection can support full mavlink !
thanks

i got it working over TCP with nano rx set to MAVLINK tx/rx and serial set to mavlink2 :grinning: :+1:
if i activate “rc over mavlink” also rc works, but sloppy.

with CRFS settings (and serial to RCIN) RC works, and i can also see the ardupilot 4.1 in my tango but cant connect via wifi. mission planner will always show “connection error” as i would connect to a wrong comport.

I have not been able to get CRSF yaapu Telem passthrough to work. with the Nano v2 Rx

I know andyp1per has it working, as well as several others in yaapu’s thread over here have it working. No idea what im missing.

I have RC (not RC over mavlink) working, telemetry sensors in openTX working, but yaapu script is not working.

Do you get regular telemetry sensors in your TX? If you do that means telemetry is basically working and its the yaapu passthrough that is broken

1 Like

Yes. That is what i was trying to say in the other thread. It feels like the data is not making it to the yaapu script, while it is making it to the radio. But to make things more odd - the Rqly:RF mode IS working within the yaapu script, but nothing else seems to show data. batt voltage shows 0.00, alt shows 0.0, no movement on artificial horizon.

we dont need to hijack another thread, and this is slightly off topic. I think the OP is talking about full MAVlink telemetry, maybe for a ground station?

yes i have no idea what yaapu Telem passthrough is sorry .
i just want mavlink telemetry with mission planner.

for me it seems that is not possible over the CRSF protocoll and the serial set to “rcin”. please correct if this is wrong
serial set to mavlink and my nano rx too + SBUS seems the best option for now.