Crop sprayer issue

Hi everyone.

I am trying to run spraying on ardurover 4.2.3 but option 15 does not come up in the RCx option section. I enabled the SPRAYER function and turned off the system and turned it on again, but I cannot assign it to the control channel. because option 15 does not come.

What flight controller? You may have to use the Custom Build Server and enable it.

@dkemxr I’m using Pixhawk orange cube. how can i enable custom server?

By going to the website Custom Firmware Builder
Checking sprayer and building then flashing the firmware.

@dkemxr thank you for your information.

@dkemxr Hi Dave;

I did custom build and although I selected the sprayer option in the payload section, the same problem still persists. When I want to assign it to the rc channel, the 15 option does not appear.

Does anyone have any ideas??

Update to ArduRover 4.4.0-beta 7 , uninstall mission planer and install the newest mission Planer. Set option 15 using the full parameter list.

Set the RCx_OPTION to 15 anyway and try it. On the latest beta version of Rover and Mission Planner on a CubeOrange+ I don’t see it shown as sprayer either but that doesn’t necessarily mean it won’t work. It could just be a Mission Planner thing.