Crius radio fail to connect with other radio -- need help desperately

I got a Crius 915 Mhz 500mW telemetry radio v1.1 with micro USB socket built in, in addition to 1.25 pitch socket.

I just plug in a wrong cable, and afterwards it cannot connect to another radio as before. The green LED still brinks, meaning it is searching for another radio.

Tried to click “Load setting”. …… Error message came out as : “Fail to enter command mode”

Tried to reflash by uploading firmware (local) and the error message is “ Could not put in to bootloader mode”.

Very sure the COM port and baud rate (57600) are correct.

Does any one know which 2 points I can short to enter bootloader mode ?

Thank you

@wcfung1 what wrong cable you pluged in and was it only a wrong cable with one loose end or was this cable powered on the other side.
Are you sure that the bourd is still connecting on this port.

Hi Juergen, Thank you for your reply.
The wrong cable (5 position to 6 position) is powered from the Telem 1 port of Pixhawk, The wiring of the wrong cable is that : 5 position plug is hooked to Crius 6-pin socket and 6 position plug is plugged to Telem port of Pixhawk.The result is 5V from Pixhawk is connected to -ve of Crius module, so no LED after Pixhawk is powered up.
More info to help solve the problem, as follows :–
Searching (talking to each other) for other radio , 2 scenarios :–
When Crius radio is in remote (on the plane) and other radio is hooked to GCS, parameters :–
Click “Load Settings” button populate Sik screen with param for both radios., as evidenced by solid Green LED.
Click “Connect” button, after timeout, error message appear “No heartbeat packet received”
When they swap position (with Crius radio hooked to GCS), 2 scenario :–
Click : LOCAL SETTING and RESET TO DEFAULT ---- error message “ failed to enter command mode”
Click : CONNECT ---- “Getting params” status bar keep moving from left to right without loading param.
Error message : “Could not put in to bootloader mode” (No red solid LED indicating firmware update)

Now that I have tried all the buttons (except “save setting”) in the Sik radio interface without success. The only way is to short 2 points to force it to enter bootloader mode so I can flash the firmware. Do you know which 2 points I have to short ?

Appreciate your help.

Hi Franki,
can you make a drawing of all pins of your pixhawk and your Crius including all pin description and which pins are connected from pixhawk to Crius. Please show all pins!
If you connected 5V to Ve- you most probably killed either the Cirius or the pixhawk or both. Your second test with the Cirius hooked to the GCS let me assume that the Crius Port is gone. If so also a firmware update will not help.

1 Like

Hi Juergen,

Pls find attached the wiring diagram of the wrong cable I used. It seems both the Crius and Pixhawk were not killed, as you can see from the 1st plugging, the 5V from Pixhawk is connected to NC (not connected ) pin, and in 2nd plugging, 5V from Pixhawk is connected to Ground, the Ground of Pixhawk is connected to Rx of Crius, not to 5V pin of Crius.

As mentioned in my previous message, settings can be populated in Sik interface in MP when Crius is used as Air module, talking to a Ground module, both with solid green LED, indicating Crius is not completely damaged. Just it cannnot enter command mode (for loading settings) nor bootloader mode (for flashing firmware)
The Pixhawk also behaves perfect without problems.

I cannot find any info about putting Crius into bootloader mode in internet. Flashing Crius is the last resort to save it.

Any hint ? Thank you for your support.

Hi Juergen,

Further to my last message, I found some info on the following link about bootloader mode :–
3DR Radio in Bootloader mode after failed firmware update - #7 by rrr6399

It involves shorting the Ground pin and CTS pin to put radio to bootloader mode. After shorting,upon power up, the red LED goes solid, meaning in bootloader mode. But after clicking the upload firmware button, it still fails…“Cannot put in to bootloader mode”.

The NC pin next to Tx in Crius is CTS pin when referencing Pixhawk pinout.

Any other clue ?

Hi Frankie,
Did your Crius link worked before you connected the wong cables correct?
Do you have a manual of your Crius. Compatible doesn’t mean identical. Very often these are cheap copies.
How you switch it before to bootloader mode?
Why you think to need a new firmware if you only made a wrong connection. This has only influence to the firmware if you select by error something like restore factory setting.
By your second wrong connection you put 5V to the complete ground plane of Crius. This is no problem as long this is the one and only connection. But you also put GND to the Rx Pin so this mean this Pin is now -5V below the GND level and this is for nearly all consumer electronic outside of the so called maximum absolute ratings and causes failure on this circuit.
From the picture of your Crius board it looks like the connector pins are directly connected to the board controller. No buffer or protection in between.
Out of all information I have it looks like at minimum your Rx Pin is gone.

Hi Juergen,
The Crius worked perfect and normal every time before connected with wrong cable. The manual is attached here :–

I did not try to switch to bootloader mode before. When I update firmware, I just click the button “Upload firmware” and the red LED is ON and become solid, meaning in bootloader mode.

When becoming desperate, I will try everything, such as flashing firmware.

Looks like I will to accept what has happened as the Rx pin is -5V.

Thank you for your support.