Servers by jDrones

Crashing apm_planner_2.0.26 on starting

(Jab Froze) #1

Hi Friends,

After successful installation of apm_planner_2.0.26_osx.dmg, when I start app planner, I get the following error on my MacBook Pro.

“APM Planner 2.0 cannot be opened because of a problem”

The problem details:

QUOTE START:

Process: apmplanner2 [1445]
Path: /Applications/APM Planner 2.0.app/Contents/MacOS/apmplanner2
Identifier: org.ardupilot.apmplanner2
Version: ???
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: apmplanner2 [1445]
User ID: 502

Date/Time: 2019-05-26 05:46:18.013 +0530
OS Version: Mac OS X 10.14.2 (18C54)
Report Version: 12
Anonymous UUID: F84173D7-A9CD-1388-3853-C2E5818F50DB

Time Awake Since Boot: 24000 seconds

System Integrity Protection: enabled

Crashed Thread: 0

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Termination Reason: DYLD, [0x3] Wrong version

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: @rpath/QtOpenGL.framework/Versions/5/QtOpenGL
Referenced from: /Applications/APM Planner 2.0.app/Contents/MacOS/apmplanner2
Reason: Incompatible library version: apmplanner2 requires version 5.9.0 or later, but QtOpenGL provides version 5.6.0

Binary Images:
0x103ced000 - 0x1048b0fff +org.ardupilot.apmplanner2 (???) <471C336F-6BAF-32AE-B650-248C86B2BF28> /Applications/APM Planner 2.0.app/Contents/MacOS/apmplanner2
0x104ce1000 - 0x104da8fff +SDL2 (3.1) <78D9C537-E977-3AD1-9890-53FBC62A4D69> /Applications/APM Planner 2.0.app/Contents/Frameworks/SDL2.framework/Versions/A/SDL2
0x10548f000 - 0x10550da67 dyld (640.2) <289AB27E-F09F-3384-A14A-100431139559> /usr/lib/dyld
0x7fff331a0000 - 0x7fff331a0fff com.apple.ApplicationServices (50.1 - 50.1) <50496459-FFDD-3A78-8D3D-A252BD9B9DA2> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/ApplicationServices
0x7fff61e33000 - 0x7fff61e45ffb libz.1.dylib (70.200.4) <15F7B40A-424C-33BB-BF2C-7E8195128B78> /usr/lib/libz.1.dylib

Model: MacBookPro11,4, BootROM 187.0.0.0.0, 4 processors, Intel Core i7, 2.2 GHz, 16 GB, SMC 2.29f24
Graphics: Intel Iris Pro, Intel Iris Pro, Built-In
Memory Module: BANK 0/DIMM0, 8 GB, DDR3, 1600 MHz, 0x80AD, 0x484D54343147533642465238412D50422020
Memory Module: BANK 1/DIMM0, 8 GB, DDR3, 1600 MHz, 0x80AD, 0x484D54343147533642465238412D50422020
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x152), Broadcom BCM43xx 1.0 (7.77.61.1 AirPortDriverBrcmNIC-1305.2)
Bluetooth: Version 6.0.9f2, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
Serial ATA Device: APPLE SSD SM0256G, 251 GB
USB Device: USB 3.0 Bus
USB Device: Apple Internal Keyboard / Trackpad
USB Device: Bluetooth USB Host Controller
Thunderbolt Bus: MacBook Pro, Apple Inc., 27.1

QUOTE END.

My system configuration is:

MacOS Mojave
Version 10.14.2

Please help me.

Thanks and Regards,
Jabelu Firoz

(Arne Wischmann) #2

Hi @Jab_Froze,

You should try this version: http://firmware.ardupilot.org/Tools/APMPlanner/daily/2019-03-08/apm_planner_2.0.27-rc1-7-g299ff23_osx.dmg

The 2.0.26 is really outdated!