Crashed my quad... help me figure out what happened

Just crashed two times today
was hoping someone with log experience can help me knowing the reasons of both crash’s

First log, 16:34:15, I was flying normally when I decided to activate RTL and the quad was going away from its home (flyaway maybe ?) , then I switched to Stabilize and quad become behaving badly… crashed on asphalt (externally only compass dome damaged!)

Then I fix the compass dome(didnt check the inside… my BAD!), put another fresh battery and was flying nicely (stabilize mode)… when suddenly at about 83meters and 65meter high (watching the kmz file… but graph log shows Alt R at above 150 ??? cant understand that too) I saw the quad rolling and falling down :astonished: tried to engage RTL but nothing stopped it from crashing on the ground!

(logs attached in a rar file)
[li]On the first log… what caused the RTL to go away from it’s home point ? And what made the quad behave badly when I tried to stabilize it and bring it to down ?[/li]
[li]On the second flight… what was the cause for it suddenly falling of the sky ? [/li][/ol]
What caused them ?

May be the second crash was a result of the first one ? Cause when I picked up the quad and disassembled it, the FC was NOT on it’s place…
but that could be from the second crash as well…

A quick ‘auto analysis’ on the second log shows:
Test: Pitch/Roll = FAIL - Roll (177.84, line 1749) > maximum lean angle (35.00)
What can cause that ?!

Also, why at mission planner log graph, sometimes I can see the time marks (1 minute… 2 minutes…), and sometimes I cant (like the pictures i’ve attached) ???

Graph 1 - first crash
Graph 2 - second crash

I’ve forgot to say that I am running stock 3.1.2 on my Quanum Nova

no one can help ?