Crash for no good reason


I’ve just had a crash - my hexacopter descended very quickly for no good reason and logs seem to be truncated.

I’m using pixhawk with DJI F550 frame and arducopter 3.3 rc7

After about 6 minutes of flying the copter switched into RTL mode (i know this from telemetry logs).
When the copter came back close to me i’ve switched it into loiter mode planning to land it manually, however at this point it descended very quickly (around line 4119240), the impact was so strong that the copter bounced and flipped itself upside down (this then i believe triggered EKF failsafe)

I’ve then disarmed the copter and turned it upside down, assessed the damage and tried to see if it flies at all and it did fly quite well considering the fact that top board is broken - it did fly without restarting or anything like that.

it seems like the dataflash logs from the SD cards are truncated early or mission planner can’t open it.

Does anybody have any ideas on what happened.

All logs are here


I had a similar crash a few days ago… Only thing I could think of is that the remote was slightly low voltage so when I tried to take over, I couldn’t. But it still doesn’t make sense. I am curious if someone else has an answer to this…