Crash due to bad accelerometer calibration

Hi, I hope somebody can help me.

I have flown with a pixhawk 2: black cube for some time with APM:Copter 3.5.0 RC4.

Everything was working fine until I upgraded to the latest ArduCopter V4.0.3.

If I take off in Loiter or Stabilise and keep the quad at a hight of a few meters it is not staying steady and crashes by falling to one side (it does not stay leveled). can this be a difference in the newer software? Nothing else has been changed.

Good day, the code of 3.5.0 is different by the 4.0.3. You must consider that now ardupilot firmware have Chibios and its different from Nuttx.
After the upgrade better perform all the calibrations needed

Also post a link to a .bin log file and say what size props you have, plus maybe some other details.

hello sorry for my bad english.
I am having the same problem. Can you explain how the problem can be solved?

I still have not been able to solve the problem. I installed the latest arducopter and did recalibration Step by step but it still crashes just after take off.

Post a link to the .bin log file, and provide a few other details about the frame, ESCs, motors, props and battery.

yes, it also comes down to me. When I look at the PWM signals with the mavlink espector and the servo output raw through qgroundcontrol, different signals go to all of them. the problem occurred with software update

@kadir_yokus, @Supersurfer PLEASEEEE Post a link to the .bin log file, and provide a few other details about the frame, ESCs, motors, props and battery.

hi bin file is on the link.
The component information used is as follows.
Motor: EMAX MT3515 650KV
ESC: BLHeli 25A
Propeller: 13 * 4.0 Carbon Fiiber
Frame Size: 700mm
Battery: 5000 mAh LiPo 4S 25C

OK, you are on AC 4.0.4-RC4. Any specific reason for that? You might be better staying with the latest stable release, 4.0.3
There’s no one thing wrong to easily fix, you need to do some of tuning work and maybe even some changes to the layout of your build. Please send a photo or two.

Issues I see:

  • the barometer readings are very strange, as if uncovered and affected by propwash and maybe even light. On a 700mm frame 13 inch props shouldnt be near the barometer, so there’s something strange going on there. A Cube Black shouldnt be having this issue :thinking:

  • You should definitely set up voltage and current monitoring

  • If you have a CAN connected compass/GPS module then set BRD_BOOT_DELAY,5000

  • I’d advise to run through the entire Accelerometer and Compass calibration routines again - wait for a good 3D Fix before you start

  • Go through this tuning guide

  • Use this helper spreadsheet to set some initial values - treat the “Suggested” values as mandatory.

I would advise DO NOT try to fly it until you’ve run through all those points or it will likely end in disaster.

You are using those ESCs with ordinary PWM (nothing wrong with that) - if you want to use DShot150 that would need a couple of extra settings, and your flight controller would need to have enough DShot capable outputs. We can come back to that after you’ve got everything else sorted.

@xfacta Hello,

I just updated v4.0.3. I adjusted everything. I completed the calibrations but the problem was still not solved. I will try your painting.pwm23

@xfacta Hello,
I just updated v4.0.3.
after the update i need to plug my battery into charge. I download a thousand after charging, I will forward it again. The PWM signals and photos from the last time I ran it were shared.

What is the take-off weight of this craft? Outputs are at max and it’s not going anywhere.

Also, you say those are carbon fiber props? They look like cheap plastic props to me.

because uav is crazy we can’t fly with propeller. tested in place in all .bin files.
uav can’t rise from any ground.

Without a .bin log from a flying copter we can not realy help you. My guess is that you have vibrations problems, but without a log, that is just a gues.

The problem was solved completely with a good accelerometer calibration.
It is not related to version update. newly acquired knowledge. :slight_smile: @Dave84 @amilcarlucas @dkemxr @Supersurfer @xfacta

After every update better perform a good calibration…happy flyyyyyy

Hi, I have finally found some time to get the .bin file for my copter.

2020-07-06 20-45-46.bin (961.0 KB)

700mm frame
15" carbon props
Motors T-motor MN4006-23 KV380
ESC T-motor Air 40A
6s Battery

It has been flying for several years without any trouble. After software update it crashes almost right after take off.
I hope you can help me.