[Crash] arducopter doesn't respond to GPS glitch and throttle down!

  1. using environment : arducopter V4.2.2 + pixhawk cube orange

  2. Crash log :

  3. Crash sequence :


~ 14:34:07 : checked satelite number is 16. although it was very short time after power on, I decided to arm and fly copter.

14:34:07 :armed copter.

14:34:07 ~ 14:34:09 : throttle up, and my copter nose was significantly raises up(about 45 degrees on the ground.) I guess this is because of GPS glitch, my GPS antenna was very close with telemetry antenna. so I suspect there was error on position estimate. I flew this copter more than 10 times before. so I guess this is not hardware issue.

14:34:09 ~ 14:34:12 : I downed throttle to zero immedietly after seeing copter nose raises up. I thought it would help drone to land. but with throttle down, copter still alive and move very fast toward me(move toward copter’s backside.) it moved about 10 meters at 3 seconds.(but it didn’t fly. it slides on the floor with his noses up) it seemed that copter doesn’t respond to me at all although I put throttle to zero all the times.

14:34:12 ~ 14:34:17 : it still doesn’t respond to me so I moved throttle stick to left side so that copter disarms.
but copter still move toward to me(to copter’s backside) and hit the stone wall. propeller was broken and copter was still alive.

14:34:17 ~ : I changed mode to stabilize and it finally disarmed. copter damaged. it is lucky that no one harmed and it was small copter.

  1. Question :

I flew many copter with many FC but experienced this first time. it is very dreadful.

although I had mistake not to wait until good GPS fix, and my telemetry antenna was very big and close to GPS antenna,
I thought throttle down + disarming would help in any situation.
with ardupilot it seems that switching mode to stabilize is only solution for stopping motors. other FC does not do like that.

ardupilot seems not check landing status very well.
in my memories I put my throttle down + left(disarming) more than 5 seconds and it didn’t respond. I think this is not good.

other FCs are very good at check landing/crash status but arducopter sometimes does not stop motors when they are on the ground(I experienced this with 3DR SOLO and many pixhawk copters before)

is there parameters about this?

First of all, you should setup an auxialiary function to have a emergency motor stop : Auxiliary Function Switches (3.6 and earlier) — Copter documentation
That’ll enable you to kill all motors using one switch on your RC. This is recommended if you don’t have an external kill switch (meaning independant from your FC).
Secondly, your ARMING_CHECK parameters are at 0. This is really unsafe. Some of my worst crashes could have been avoided if I had left it at 1. Your FC could have warned you of any problemes before arming.
Finally, I don’t know what caused your crash, but here’s what’s bugging me on this log :

  • motor 2 might have some problems, it stays at zero for some time
  • is your controller calibrated ? Your pitch (RC2) command stays 1625 almost all the time
  • Also, your VibeZ is a bit higher than acceptable (>30m/s²), you should check your motor mounts and props because high vibe can cause bad position estimate.
    • is your controller calibrated ? Your pitch (RC2) command stays 1625 almost all the time
      ← I calibrated my controller and flew it more than at least 10 times. it hovers well and calibrated well.

but my transmitter’s spring is bit loose and sometimes I found screen goes blank when the power is on , after inactive long time. it is definetely weird(I’m using X9D)

so I think transmitter is the cause of problem, not the GPS glitch.
thank you. I could find problem with your information. I will dig into this problem.

  1. your ARMING_CHECK parameters are at 0.
    ← yes, my arming_check parameters are at 0.
    I turned off it very long time ago because there was some problem. but I entirely forgot that fact. sorry.
    I thought there will be EKF message or something for bad GPS.
    this crash is my mistake.

  2. with prescence of stabilize mode now I think I don’t need emergency motor kill swtich… thank you

    • motor 2 might have some problems, it stays at zero for some time
      ← I think this is because my quad slide above ground and touched the wall. but I’m not sure.
      this is another log after this crash. I changed props after crash and flew it again. it flew well.
      could anyone can see something problem with my motor?


  1. your VibeZ is a bit higher than acceptable (>30m/s²),
    ← I think this is because my quad hit the ground and the wall. but I’m not sure.
    could anyone reference my log attached above?

**PS : someone edited my post with their authorization because there is useless indentation on my post
but even after editing, my article remains same(there is useless indentation) because this forum’s text formatting system automatically insert indentation.
There is a problem when you try to organize the contents of the article by attaching numbers.
I don’t know why this happens but I don’t want automatic indentation. I want some revision of text formatting system. I will upload another post about this.

I don’t see any problem with motor 2 on this log, however it seems that your drone is a bit underpowered. The mean RCOUT PWM is above 1700, which means you are using 70% of the available power just to hover and move a little bit. You might want to lighten your drone, or use bigger motors.

Your Yaw vs DesiredYaw is weird. I see Yaw oscillations when you have zero Yaw input.
You should check and improve your PIDs.

Battery current seems also weird to me, it is extremely noisy (it oscillates between 5 and 9 A).

Vibe is ok on this second log (<=15m/s²).

yes, my quad is surely underpowerd. I’m already using big motor and big battery. I should change prop to long one. I will overlap my props.(with different motor mount heights)

my cube power module need to be calibrated.

I suspect this accident caused current oscilliation. my cube power module shocked one time before.

and I actually saw yaw oscillations with my eye, while I fly my quad.

it seems that I need autotune, but after I solve some problem(about current and yaw imbalance. yaw imbalance is not in uploaded log but it was persistent problem.)