Could use some help analysing this crash


I’m trying to analyse a crash but I’m not really sure about what happened. I was wondering if someone with more knowledge about APM could help me out.

I’m fairly new to the hobby and after crashing my first quad due to cheap props, I build a new one. All the same parts, but on a new frame. My first flight went ok, but the battery made it dangerously out of balance. (See Picture) So I soldered a wire harness and mounted the battery on the bottom, in the center. After this, the quad flew okay, but kept yawing. Sometimes to the left, sometimes to the right. Besides that I wasn’t happy with the vibrations. I thought they might have something to do with the yawing, so I decided to work on that.

Today I rebuild the copter with better vibration dampening. And since I was rebuilding parts of it, I decided to change the wiring a bit as well. To be able to get the ESC’s mounted on the legs, I had to extend the servoleads. I did this by cutting the wire and soldering it to half a servo lead I had laying around. So now I have two ESC’s at the front with longer servo leads than the two on the back.

Tonight I went to my designated fly-zone and tried it out. Since I already lost one set of carbon-reinforced props, I decided to first try it with my cheap props. It flew great. Liftof was much better and it was calmer in the air.

After having a lot of fun with the first battery, I connected it to my laptop and downloaded the logs. I changed the cheap 9x4.75 props for carbon-reinforced 10x4.5’s. Because I still didn’t have a stable yaw, I changed the yaw P value from 5.5 to 6.5. I’m pretty sure my remote was off at this point and since I have the pitch/roll P value connected to a pot switch, I think I wrote a value of 0 to the Stabilise Roll P and the Stabilise Pitch P. (I realised this after the crash.) Besides that I saw channel 8 blink red when I wrote the values. I didn’t think much of it since I don’t have channel 8 connected to my receiver at this point.

I disconnected the laptop and connected the battery. At this point I realize that I have the remote turned off, so I turned it on. I armed the engine and attempted to take off. The quad immediately tilted to the left. I disarmed it and checked the props. They weren’t harmed, so I decided to try again. With my current setup the battery cable is on the ground, lower then the landing gear, so I thought that was the reason that I tilted to the left.

My friend said to take of a bit more determined because of that cable, so I did. Immediately after taking off I had the feeling that I didn’t have control and since I have pretty powerful engines, it went to it’s front-left pretty quick. I tried to get it back under control and towards me, so I pitched back. The quad immediately dipped it’s back and started to fly backwards (and still a bit to the left). At this point I was wondering why it wasn’t stabilising. After centering my control stick it kept going in that direction, as if it was set to acro mode. I realised that it was going to crash and I tried to crash it as softly as possible. I did manage to save most of the quad.

I have foldable arms with two bolts. One bolt is the alu bolt that came with it, the other one I switched for nylon bolts. Three of the four arms had their nylon bolts broken, so that turned out to be a good idea. The third bolt didn’t break, but the plate that my engine is mounted on did. This plate, a lipo, my volt meter,a few nylon bolts and a set of props is the only damage, I’m pretty happy that the frame didn’t really break this time.

When I got home I connected the APM and got double red. I noticed that it was failing the ACRO_BAL_ROLL/PITCH PreArm check. This let me to believe that connecting the battery before I turned on the remote was the reason I crashed.

Besides that I have some trouble analysing the log files. I find the pitch and roll values pretty weird. The attached log shows:

0 - Battery connected, but almost no data.
~470 - Attempt at taking off, but the quad tilted to the left
~680 - Disarm
~1050 - Take off.
~2000 - Crash that disconnected the battery.

Now for my questions:

  1. Could the remote being turned off when the APM got turned on be the reason that it somehow actually used a value of 0 for roll/pitch stab P?

I would think that the values should be set properly after turning on the remote. It does seem to do this when I have it connected to mission planner and turn on the remote. Besides that, I didn’t fail the PreArm check. So it must have seen a value higher than 1.

Flying was weird though. Like I said, it felt like it was on acro mode. I haven’t used acro mode on the APM yet. (only the manual mode on my Blade Nano QX, it felt like that.) It was moving away from me and I wanted it to come back. I pitched back and the quad responded. It didn’t stabilise after that though.

  1. Could the longer servoleads on the front engines cause any problems? Especially since they are longer than the leads on the back engines. Since it’s just a signal cable, I figured that this wouldn’t be a problem.

Thanks for reading,

Pictures are here:
APM Log is attached

Nice vibration dampening. Can’t really help you on the clock because of the clones, but probably compass issues due to the wires running underneath the APM.


It did seem to be the compass. When I connected the quad to USB it appeared to roll while pitching. Someone on Reddit recommended setting the compass position/orientation to NONE instead of ROTATION_ROLL_180. This made that problem go away.

I’ve now rebuild the quad and with nearly windless weather I have vibrations on average below 1. So the vibration dampening works great. It loiters much better as well.