Correct position in Mission Planner but not in Tower/Droidplanner 1 and 2

Hi All,

After using APM for several years I migrated to Pixhawk. Now I’m facing a new challenge:

  • My position in Tower in in front of the coast in Africa and not in the Netherlands where I live
  • the strange things are:

does anyone have an idea?

and the same with the QGC app on my android tablet.
Compas is working
3D fix, 18 sats but also wrong position

it even gets more exciting :slight_smile:

I simplified to just pixhawk and GPS connected via usb to my windows pc
according Mission Planner I’m in the Netherlands

and according QGC I’m in Africa

and I’m using this version

Just an observation - the location you’re seeing in QGC and Tower corresponds to 0,0 latitude and longitude. Could be that the GPS is not reporting a solution or the GCS app is not interpreting it properly?

I tried a copter firmware and than all works properly, seems to be a bug in the ardurover software

I have tried earlier versons of Ardu Rover and 3.0.1 is the last working version. All versions after this have the same issue.
This is a screenshot Tower is working with 3.0.1

I have tested with Tower and Rover and I can replicate the issue. Also note I tested with Plane as well and it has the same issue. If you have it working with Copter then Copter is the ONLY vehicle it works with. As MAVProxy and MissionPlanner are both working with all vehicle types I suggest its a problem with Tower and possibly QGC (I didn’t test QGC) so you may wish to raise this issue with them.

Thanks, Grant.

Ok I built and tested with QGC on my Linux machine and QGC works fine. I also installed QGC from the Android Play Store onto my Android Tablet (old Nexus 7) and it works fine there too. I tested both Rover and Plane. So from my observations only Tower isn’t working correctly.

Note I am running the latest BETA version of Plane and Rover.

Thanks, Grant.

Hi Grant,

I tested latest beta version of Rover (3.2.0 Beta 1) and all is fine. The problem only seems to be in Rover 3.1.2!
I will start using this beta version.


That is very odd but great news that its working for you in the latest Beta. If you have any other Beta feedback please let me know.

Thanks, Grant.

iemand een oplossing voor een apm ook heb net zelfde voor als bas,
apm rover versie 2.51 beta welke versie werkt wel correct


I’m afraid we don’t support the old APM boards anymore. Maybe someone else can help but I suspect there are just too few people using these old boards.

just support pixhawk?


ArduPilot supports a ton of boards including the Pixhawk. Most of them are listed here.