Copter v3.5.5 autotune not work

Just upgrad quad from v3.4.6 to v.3.5.5 , but unable to switch to autotune flight mode, or at althold/poshold mode switch CH7/8 can’t get into autotune mode. HUD show flight mode change fail. any one has same problem?

What mode are you trying to switch from?

Do you have position lock when attempting to switch?

both poshold and althold . GPS lock

If it is on ground [not flying] , I think mode change to Auto Tune will fail.

I had this happen to my 30" propeller quad recently & found that the problem was that the initial manual tune before attempting the AUtonue was too unstable/reactive (PID’s were too high) & that the Autotune would not function as the copter never settled for enough duration for the Autotune to commence.

Try lowering your ATC_RAT_PIT_D / ATC_RAT_PIT_P and ATC_RAT_RLL_D/ ATC_RAT_RLL_P by 50% of their value & attempt the Autotune again. (Make sure you check that the copter feels in good control to stick inputs first)

If it doesn’t go into Autotune lower by another 50% & try again, etc. (If the copter feels unstable abandon this method as you may have another issue)

Good luck

Watching this thread, I have the same problem.

You could try extending the dead zone at mid throttle.It has to be pretty much dead centre to engage so a bit of uppy downy in stabilize and alt hold will settle mid throttle value.Then try it again.You can use Autotune as a flight mode on your normal channel 5 switch.Makes life a bit easier.

I had the same problem and it took´s for weeks to find the right solution.
Have a look at the parameter CH3_Trim. This should be in the same range like Ch1,2 and 4 - nearly 1500.
If it is not in this range PosHold and AltHold will work, but not Autotune.
I think this problem started with Copter 3.5.3 or 4 - I have had no Problems with 3.4.x and with the first releases of 3.5.y.
After changing the paramter Autotune works fine for me.

Best regards,

thank your comments, I will give it a try

How do you make ch3_trim same as ch1,2,4? just go to full parameter list and fill 1500 for ch3_trim?

The easiest way to set ch3_Trim to 1500 is to change the value in the full parameter list. The normal way is to do a new radio calibration with starting all channels (sticks) in the mid position.

Channel 3 trim should only be set at zero…All set in a radio calibration where it tells you to centre your sticks and lower your throttle to zero.It has no effect on the mid throttle position when flying.That is set by the FC after a short flight with throttle learning on.

what I did :-
set throttle learning on & Save. Fly 1.minute in Alt hold or Poshold and switch to AutoTune mode.

thank all, lean a lot from here.