Copter stopped Arming - no error messages to identify the problem

My copter stopped to arm with no error message.

I have had this issues sometimes with Cube Orange and Arducopter 4.0.7 (CUAV NEO V2 PRO CAN) and now with 4.1.3. My setup as a Cube Orange, 4.1.3, CUAV NEO 3 Pro CAN GPS.

Today on test flights, the copter was flying normally but afer some flights there was no way to arm again. I was getting over 25 satellites. When trying to arm with the throttle stick, I get a arming noise, ARMING message on Mission planner for about 1 to 2 seconds and message disarmed shows again (and does not arm). There is no other message to give an idea what this could be. I even turned off all pre arm safety checks but nothing changed. On previous days with this problem, I just switched to AUTO - RTL and back to LOITER and Arming was possible. Not this time. I turned logging on (LOG_DISARMED,1) in order to find the problem but I was not able to. I have made a copy of logs with this problem. I would appreciate if some could take a look and send a clue on what could be happening.

Thank you.

I am suspicious about RC7_OPTION=31 (Motor Emergency Stop).
Can you set RC7_TRIM = 1500 and try?
Its trim is set to the lowest value.
I never used the EStop but just guessing.

OK, so I think I got it.
So in the arm logs:

For disarm, the method is 17, which is related to DISARM_DELAY in the code.
And when I look at the parameters of yours, I saw DISARM_DELAY=1.
This means that, after the arm, disarm in 1 second.
Increase it to something like 10-20 seconds.
This probably solves the problem.
Let us know if it won’t.

Mustafa you nailed it!

I changed DISARM_DELAY=2 and is woked perfectly every time (and it does not arm when I change it back to 1). I need fast DISARM since I produce big crop spraying copters (25 - 60Kg MTOW) and I had problems to turn off motors after landing.

Thank you very much!

1 Like

When there’s disarming problems, the real cause can be landing detection is not working properly due to vibrations and less-than-ideal tuning. Quite often better tuning (and Harmonic Notch Filter) fixes things like this.
I use DISARM_DELAY,5 to allow enough time to arm and raise the throttle, but also disarm soon enough when landing.


Our problems with disraming on landing (AUTO or manualstopped after turning on the “GND_EFFECT_COMP,1” and “PILOT_THR_BHV,4”. But I needed faster response on manual disarming and we found out the hard way that 1s is to low for DISARM_DELAY. 2s works fine.

Thanks for your comments.

Friendly advice…
With that big bird, probably you have low Kv motors.
I suggest you after arming and disarming, wait for some seconds (at least let’s say 5 seconds) to give motors some time to turn at their idle rpm.
You might get some strange noises from motors and they don’t produce enough lift to take off until disarm and arm again with waiting proper amount of time.
I don’t know whether this harm the motor and/or electronics or not, but its really scary :slight_smile:
Hope you didn’t face something like this.
Friendly advice ended…