Copter RATE tuning help

Hi guys.
we are tuning a really big copter now, we’re following the tuning instructions here
this is the setup:
1.frame size 115cm
2.motor is hobbwing X6 with the ESC intergrated, link’s here with the 2388 props
3.battery’s are 12S 10P’s 18650 weight 13kg
first take off both the roll and pitch has lots of oscillations, we reduce the roll and pitch’s P and I term, finally the copter is not oscillate any more, I try to digg more about the log then I find the RATE.RDes RATE.R RATE.PDes RATE.P is very strange, There are lots of oscillations on it , I take look another copter log and It’s totally different, what’s those data meaning? and how to tune that?
log’s here

Here is today’s log

I reduce the ATC_RAT_RLL and PIT P I to the 0.067 It’s much more better then last time, This copter is bit strange, the wki said the P I normally at 0.08 to 0.2. but RATE.RDes and RATE.R is still not good…

I think that reason is high ATC_RAT_RLL_D value, but 10Hz not enough for checking it. You can set ATTITUDE_FAST in LOG_BITMASK parameter (attitude info at 50Hz) for manual tuning PIDs, it will give much more information

There’s some serious noise and oscillations going on there.

And motor outputs are correspondingly “noisy” too.

My personal preference would be take the PID tuning off the TUNE ch6 unless you’re an experienced tuner - it generally causes more confusion than good.

I’d set these and do a test flight with some hovering and gentle manoeuvres.

The ones to check are:
ATC_INPUT_TC - adjust higher for softer RC control, even try 0.22
MOT_SPIN_ARM - check with MP motor test for minimum reliable startup
MOT_SPIN_MIN - just starting to produce thrust, usually approx _ARM +0.05
MOT_THST_EXPO - I suspect those ESC’s are slightly more linear than most, you might be able to go lower with this param. Here’s what to look for once the rest of the tuning is done:

You can copy/paste that whole list of params into a text editor and save as a {some_name}.param file then load it via MissionPlanner (compare) to avoid all the typing errors and ages trying to find them all.

Please let us know the outcome of the next test and post another .bin log

Thanks shawn,
This is a lot of information to process to me, I’m not a good tuner now, but I want to be a good tuner, so I will stick with the ch6 tuning knob. I’ll read the leonard’s post very carefully and try to understand the advanced tuning.

Hi shawn,
@xfacta sorry to bother you again, as your suggested I set the

  1. ATC_INPUT_TC,0.2
  2. MOT_THST_EXPO,0.72(little bit lower than you suggested)
  3. PSC_ACCZ_I,0.6
  4. PSC_ACCZ_P,0.3

but not the MOT_SPIN_ARM, cause I don’t like the motor spin right after the copter armed. and also I leave the MOT_SPIN_MIN and BATT_x at the default. we have 2 battery monitors on the battery, I think It’s enough for the tuning. also I enable the PID log, ATTITUDE_FAST log and INS_LOG_BAT_OPT=0 to get the FFT analysis.
anyway, I think the set is ok, and the copter is bit better than yesterday, still noisy on erverywhere though. but the biggest problem is the copter suddenly started spinning in poshold mode, at that time I think It’s a compass issue, then I switch to the althod, but the spining is not stoped, the yaw is totally out of control, but I sill was able to land the copter safely, after the land I try to fly it again, but still spinning, compass is designed by myself, as i discussed in aother post, and It’s fine, and I got home, I noticed one motor is not balanced, It’s balanced last time,maybe it’s a mechanical issue, so I think It’s the reason that copter spinning, but after I check the log I found the ATT.DesYaw is spinning too. here’s the first and second flight log.
first log
second log