Copter Pirouettes on Guided Takeoff with RC2

We tried out RC2 the other day and noticed that the copter did a single uncommanded pirouette on guided takeoff:

Reverting to RC1 fixed the problem.

I can’t see what you mention.

The yaw image shows a wrap between 0 and 360 but in real life it should not mean a 360 turn around but just a mathematical way of representing yaw.

Did the copter really did that yaw movement? I mean did you see it with your eyes?

From the graph above it looks like it was commanded to face north and did so.


Yes, on takeoff it spun about 1 revolution. The guided takeoff command does not specify a yaw angle so it should not have tried to orient itself to North. This only showed up in RC2, RC1 did not do this. I did notice that the CONDITION_YAW for AUTO seemed a bit more reliable in RC2.

Mind posting the full log file?

I tried to duplicate the problem at my local park here in Austin, but the copter refused to do it. I wonder if it is related to this issue:
Perhaps my other location had a large iron deposit beneath the takeoff location.


I had another look at your log and I think it’s a different issue. I’m not sure why I didn’t see it earlier (perhaps there were just too many other issues clouding things) but in your log the desired yaw rate jumps massively as you switch to Guided mode. I’m sure this is an initialisation problem and I’m pretty sure we’ve fixed this but I will check through the commits.

Here’s a graph of the desired yaw rate (in red) vs the actual yaw rate (in green).