In monitoring EXTENDED_SYS_STATE for Copter 4.2.0, MAV_LANDED_STATE_TAKEOFF never gets reported. Upon takeoff it goes straight from MAV_LANDED_STATE_ON_GROUND TO MAV_LANDED_STATE_IN_AIR. Is this a bug, or intended for Copter?

@BrunoBagarini I am not sure what I am missing on this topic, but I have not seen any feedback. Perhaps flagging it for the Dev Team is not correct. Who would be good to look at this topic and provide some feedback?

Really not much into this subject matter.

Is it affecting your operation somehow?

Yes it is. we use the landed state to trigger various actions on our edge computer.

Should work, depends how your taking off. It will only be set in a auto takeoff.

We had it working consistantly, and then it became sporadic. Not sure if there is a bug in the arducopter 4.2.0 firmware.

We flew this morning again. Auto takeoff. Extended System state reports states 1, 2 and 4, but not 3. 3 should be MAV_LANDED_STATE_TAKEOFF as per MAVLINK documentation. The flight controller would start reporting 1 (MAV_LANDED_STATE_ON_GROUND), then when it takes off report 2 (MAV_LANDED_STATE_IN_AIR) and then when it lands 4 (MAV_LANDED_STATE_LANDING).

Previously with an earlier release of arducopter it consistantly reported 3 when taking off. Not with the v4.2.0 release.

@rmackay9 who do we reach out to when the flight controller is not consistently reporting through the EXTENDED_SYS_STATE parameter MAV_LANDED_STATE_TAKEOFF when taking off in auto and other modes. Prior to Copter v4.2.1 we had no problem with this being reported when taking off in auto mode. Lately it is sporad in reporting the drone taking off. It reports directly MAV_LANDED_STATE_IN_AIR. Has there been a code change?

OK, so I tried this on ArduCopter V4.3.0-dev
I tried this with long 511 245 500000 0 0 0 0 and watch EXTENDED_SYS_STATE in MAVProxy in GUIDED mode takeoff.
I am able to get MAV_LANDED_STATE_TAKEOFF (which is 3) during takeoff in GUIDED mode until reached the required altitude.
However, in AUTO mode, it goes straight to MAV_LANDED_STATE_IN_AIR as you said.
Seems like you found a bug :slight_smile:

Edit: I did a quick PR that seems to be able to fix this issue.


Thankyou. Whith which release do you suspect a correction in the code? v4.3.0?

1 Like

4.3 and surely the next 4.2.X too

1 Like